Bug 116124 - LO Impress PDF Export "Notes only" or "Notes" does not export embedded pictures
Summary: LO Impress PDF Export "Notes only" or "Notes" does not export embedded pictures
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Keywords: corruptProfile
Depends on:
Reported: 2018-03-01 16:59 UTC by do.weller
Modified: 2018-11-12 16:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

PDF without pictures (382.26 KB, application/pdf)
2018-03-01 17:00 UTC, do.weller
ODP with pictures (22.18 MB, application/vnd.oasis.opendocument.presentation)
2018-03-01 17:02 UTC, do.weller
printscreen from my export (195.02 KB, image/png)
2018-03-03 15:23 UTC, raal

Note You need to log in before you can comment on or make changes to this bug.
Description do.weller 2018-03-01 16:59:05 UTC
If you click File /Export as PDF and set Note (Notizen) or Notes only (nur Notizen) the resulting PDF does not contain all of the pictures. 

LO Version: 6.x / Build-ID: 60bfb1526849283ce2491346ed2aa51c465abfe6

This Bug is also part of LO 5.4.5 (up to date DEB package from today)!

This Bug is not part of LO as in Ubuntu 16.04.x up to date (could be 5.2.x?). There this export works without flaws.

Steps to Reproduce:
1. Import pictures to LO Impress slides
2. File /Export as PDF
3. Set "Notes only"

Actual Results:  
Pictures are not part of PDF

Expected Results:
Pictures should be part of PDF

Reproducible: Always

User Profile Reset: No

Additional Info:

User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 do.weller 2018-03-01 17:00:11 UTC
Created attachment 140265 [details]
PDF without pictures
Comment 2 do.weller 2018-03-01 17:02:19 UTC
Created attachment 140266 [details]
ODP with pictures
Comment 3 raal 2018-03-03 15:23:00 UTC
I can not confirm with  Version:
Build ID: 44b4ad7d210097fdaed7dd94c5746b03f43592d3
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 

At your PDF is PDF os clide 7 missing (slide Basis für sub-/parastaatliche Strukturen), but in my export is picture present. Seems to be fixed with dev version. Please could you test it with dev version?  You can download it here:
Comment 4 raal 2018-03-03 15:23:51 UTC
Created attachment 140312 [details]
printscreen from my export
Comment 5 QA Administrators 2018-09-03 14:49:49 UTC Comment hidden (obsolete)
Comment 6 Alex Doll 2018-09-20 15:52:25 UTC
It looks like there is a problem with the X.Y position of images in Impress when exporting.  I've had examples of a picture that was scaled back to its original size (I had shrunk it to fit onscreen) and then the x.y was positioned too far left/down so only half the oversized picture appears on the screen.

Changing pictures by Convert to > curve can solve this, but it requires ALL pictures, metafiles and other "picture" type objects to be converted manually.

Tried using the latest Apache/OpenOffice, it doesn't suffer from this (but it doesn't have a Notes Only PDF option, either).

Running LibreOffice Linux from OpenSuse
Comment 7 Alex Doll 2018-09-20 21:08:47 UTC
Possibility observed working with this bug some more, is there a variable related to the x.y position of an image that is not reset to zero when a new page is rendered?  One behaviour I saw appears like the x.y from the previous page got summed with the x.y of the current page; adjusting the previous page makes the current page change.
Comment 8 Alex Doll 2018-10-12 15:51:50 UTC
Experimenting with this, I took an image that wasn't rendering and I converted it to "curve" and the image then appears in the PDF correctly. So a dirty fix is to convert your images to "curve" or "polygon" before exporting as PDF.

But there are still examples where it will not work.  I tried the same with a different metafile (a "group" consisting of a chart and some annotation text from LO Sheets) and the image vanished.  Fighting with this some more, I tried reducing the size of the image to a postage-stamp and moved it to the top-left of the slide.  Triggering "convert to curve" then functioned, but the image jumps about half-way down the slide.  This looks to me like a positioning problem of the same sort as observed in the PDF output vanishing.
Comment 9 Xisco Faulí 2018-11-12 12:10:36 UTC
Dear Do Weller,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 10 Alex Doll 2018-11-12 16:17:28 UTC
This fix works on three different presentation I've run.  I'll wait for the other reporters to confirm, but I recommend changing status to 'resolved'.
Comment 11 Xisco Faulí 2018-11-12 16:28:13 UTC
Thanks for retesting with a clean profile.