Bug 116188 - UI Dialog requires gtk 3.20
Summary: UI Dialog requires gtk 3.20
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Hardware: All Linux (All)
: medium minor
Assignee: Caolán McNamara
Whiteboard: target:6.1.0
Depends on:
Blocks: GTK3
  Show dependency treegraph
Reported: 2018-03-04 16:31 UTC by Ulrich Gemkow
Modified: 2018-03-06 11:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Gemkow 2018-03-04 16:31:29 UTC

the following dialog requires gtk 3.20:


<?xml version="1.0" encoding="UTF-8"?>
<!-- Generated with glade 3.20.2 -->
<interface domain="sc">
  <requires lib="gtk+" version="3.20"/>

Even in Ubuntu 16.04 LTS (which is a rather current distribution) only gtk 3.18 is provided. Is this requirement really intented?

Thank you!
Comment 1 Julien Nabet 2018-03-05 09:17:55 UTC
Caolán: since it concerns gtk 3, thought you might be interested in this one.
Comment 2 Caolán McNamara 2018-03-05 14:31:14 UTC
We have a min of 3.18 for the runtime so I'll set all the .uis to that same version. IIRC there was some discussion of switching the min from 3.18 to 3.20 around April. But for the moment its supposed to be 3.18.
Comment 3 Commit Notification 2018-03-05 20:27:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":


Resolves: tdf#116188 set min version on all .ui files to 3.18

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:

Affected users are encouraged to test the fix and report feedback.