the following dialog requires gtk 3.20:
<?xml version="1.0" encoding="UTF-8"?>
<!-- Generated with glade 3.20.2 -->
<requires lib="gtk+" version="3.20"/>
Even in Ubuntu 16.04 LTS (which is a rather current distribution) only gtk 3.18 is provided. Is this requirement really intented?
Caolán: since it concerns gtk 3, thought you might be interested in this one.
We have a min of 3.18 for the runtime so I'll set all the .uis to that same version. IIRC there was some discussion of switching the min from 3.18 to 3.20 around April. But for the moment its supposed to be 3.18.
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":
Resolves: tdf#116188 set min version on all .ui files to 3.18
It will be available in 6.1.0.
The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
Affected users are encouraged to test the fix and report feedback.