Bug 116261 - CALC FORMATTING changing the format of some characters of a text cell (interpreted as formula?)
Summary: CALC FORMATTING changing the format of some characters of a text cell (interp...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Direct-Formatting-Parts
  Show dependency treegraph
 
Reported: 2018-03-07 10:25 UTC by Elyse Cordeau
Modified: 2021-06-13 03:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Try to change the color of some characters of the cells A2, A3, A4 or A5 (16.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-03-07 10:25 UTC, Elyse Cordeau
Details
The bug, step by step, with images (7.38 KB, image/png)
2018-03-07 15:48 UTC, Elyse Cordeau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elyse Cordeau 2018-03-07 10:25:51 UTC
Created attachment 140421 [details]
Try to change the color of some characters of the cells A2, A3, A4 or A5

It seems that calc interprets some text cells as a formula when it comes to formatting.

1) I type in a cell a text that starts with the character '+' or '-', and that this text contains at least once a cell reference (ex: "+ foofoo A7 foofoo")

2) If I change the color of some characters (not the whole cell!), for example the 2nd foo (ex: "+ foo<foo> A7 foofoo"), it works.

=> Here, we already see that A7 becomes blue as if it were a formula.

3) But if you modify the cell (selection, add a space, ...), the color goes away.

Yet I tried to see with TYPE or ISFORMULA functions, but these cells look like text (left alignment).
Comment 1 Jacques Guilleron 2018-03-07 14:59:53 UTC
Hi Elyse,

I don't reproduce with
LO 6.0.2.1 Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Can you precise your OS, please?
Comment 2 Elyse Cordeau 2018-03-07 15:48:13 UTC
Created attachment 140442 [details]
The bug, step by step, with images
Comment 3 Elyse Cordeau 2018-03-07 15:52:34 UTC
Hi Jacques,

Thank you for your test!

I tested both on linux and windows and get the same behaviour.

Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 2; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group

Version: 6.0.2.1
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

But perhaps I did'nt explain it clearly (sorry for my english), so I added an attachment with images.
Comment 4 Xavier Van Wijmeersch 2018-03-07 18:30:10 UTC
confirm  with

Version: 6.1.0.0.alpha0+
Build ID: a790ee54319583897d82d4372243df870d4452a6
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 5 Jacques Guilleron 2018-03-07 18:59:07 UTC
This time, I reproduce it.
However, when I isolate + by putting it between quotes, I don't reproduce this effect. Do you agree? And it seems to happen only with this key/operator.
Comment 6 Jacques Guilleron 2018-03-07 23:09:20 UTC
Try this also with
LO  3.5.3.2 Version ID : 235ab8a-3802056-4a8fed3-2d66ea8-e241b80 under Windows 7 with the same behavior.
So probably inherited from OOo.
Comment 7 Xavier Van Wijmeersch 2018-03-08 07:52:38 UTC
Hu Jacques,

I tested with AOO 4.2.0rc and yes the same behavior.
And putting a ' before the + then everything works fine.
Gnumeric has a warning to re-edit or to accept the input.
When accepting then it auto put a ' in front of the +.
So it could be a nice future as well for LO.
What you think about it???
Comment 8 Thomas Lendo 2018-03-13 22:30:35 UTC
Elyse, do you work on a patch for this as you are the assignee? Please only assign a bug to yourself if you work to fix it in the source code.

I downloaded the attached file and tried the steps in A15. As a result, the red colored text is only changed to blue during cell editing (then LibreOffice handles 'A1' as a formula reference to cell A1). After leaving the cell, the text is red again.

But if I colorize 'ffero' behind 'A1' in red, edit the cell and add a space at the end of the cell text and then go to another cell, then the red color of 'ffero' is gone.

Version: 6.1.0.0.alpha0+ 
Build ID: cab04bc39b5164ea74216cd849c3af5f5b298f79
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 9 Xisco Faulí 2018-06-12 09:27:50 UTC
Dear Elyse Cordeau,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 10 QA Administrators 2019-06-13 03:00:31 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2021-06-13 03:48:10 UTC
Dear Elyse Cordeau,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug