Download it now!
Bug 116284 - Exported PDF provides invisibly-corrupted text for copy-and-paste
Summary: Exported PDF provides invisibly-corrupted text for copy-and-paste
Status: RESOLVED DUPLICATE of bug 115117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.4.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-08 00:50 UTC by Jim Avera
Modified: 2018-03-24 00:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bug.odt (see steps to reproduce) (15.20 KB, application/vnd.oasis.opendocument.text)
2018-03-08 00:51 UTC, Jim Avera
Details
bug.pdf (results when I did File->Export to PDF) (13.20 KB, application/pdf)
2018-03-08 00:52 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2018-03-08 00:50:20 UTC
Description:
The attached .odt file, when converted to pdf, as a strange problem: Certain areas of text can not be copy-and-pasted correctly.   The copied text is silently corrupted, causing certain characters to be dropped or duplicated.  Very strange.






Steps to Reproduce:


1. Open attached "bug.odt" and do File->Export to PDF
   (or open the attached .pdf)

2. Open the .pdf file.  Select the string "critters@example.com" with the mouse, and then Control-C to copy.

3. Put cursor in a terminal (e.g. gnome-terminal) window.  Control-Shift-V to paste.


Actual Results:  
Something else is pasted (a corrupted version of the text).

Expected Results:
What is displayed should be copied.


Reproducible: Always


User Profile Reset: No



Additional Info:
NOTE: In real life, the problem arises in files which have been modified by non-LO software (The ODF::lpOD perl library), and seemingly only in tables.   I have not been able to reproduce it with text entered manually.  The attached demo file is a cut-down copy of a user directory generated from a database using a software tool.



User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Jim Avera 2018-03-08 00:51:29 UTC
Created attachment 140456 [details]
bug.odt (see steps to reproduce)
Comment 2 Jim Avera 2018-03-08 00:52:08 UTC
Created attachment 140457 [details]
bug.pdf (results when I did File->Export to PDF)
Comment 3 Jim Avera 2018-03-08 01:05:51 UTC Comment hidden (obsolete)
Comment 4 Jim Avera 2018-03-08 01:46:42 UTC
Further narrowed it down: 5.4.0.1 fails, but 5.3.7.2 works.
Comment 5 Timur 2018-03-08 10:44:31 UTC
I guess it's a ligature issue and dupe of Bug 66597 like other duplicates with Calibri and Carlito fonts.

*** This bug has been marked as a duplicate of bug 66597 ***
Comment 6 Jim Avera 2018-03-08 18:05:50 UTC
So what changed in 5.4.0.1 to make this problem appear?

The exact same .odt does not create wrong PDF in 5.3.x
Comment 7 Khaled Hosny 2018-03-20 02:23:38 UTC
Bug 66597 is becoming a kind of meta bugs with different issues lumped together, lets separate different issues.

*** This bug has been marked as a duplicate of bug 115117 ***
Comment 8 Jim Avera 2018-03-24 00:04:22 UTC
Confirming that this one is fixed in latest master.