Bug 116377 - If I write the text and then highlight it and insert a section I cannot keep writing underneath the section in a new paragraph
Summary: If I write the text and then highlight it and insert a section I cannot keep ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2018-03-13 11:37 UTC by Daniele
Modified: 2018-04-07 11:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Section (9.69 KB, application/vnd.oasis.opendocument.text)
2018-03-13 14:01 UTC, Daniele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele 2018-03-13 11:37:54 UTC
Description:
When I insert a section in Writer (for example, I write some text that I want then to be distributed over 2 or more columns), if I do this before I write the text that I want to be part of the section (i.e. I create the section and then I write the text into the section), I cannot leave the section. I cannot start a new paragraph underneath the section. I apologise if that may not be a bug but I could not find any solution online rather than type the text first, press enter to start a new paragraph and then highlight the previous text and insert a section. 

Steps to Reproduce:
1.insert section
2.choose the columns layout
3.write the text into the section

Actual Results:  
impossible to exit the section and write a new normal paragraph underneath the section

Expected Results:
should be able to click underneath the section in a blank point and start writing a new paragraph


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6
Comment 1 Dieter 2018-03-13 11:54:58 UTC
When I insert a section, the section is always inserted before the paragraph where the cursor is located. So there is always at least one paragraph below the section.

I tried it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d64ce643275e0b2b0dea9e532fc261391dc8793c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-01_03:24:30
Locale: de-DE (de_DE); Calc: CL

and

Version: 5.4.6.1 (x64)
Build-ID: 7d6c666f03cf1f0a0c2c51a17c0f67a8d5a8012b
CPU-Threads: 4; BS: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

=> Perhaps only a Mac issue?
Comment 2 Timur 2018-03-13 12:49:10 UTC
Please make a screencast with Formatting Marks on.
Comment 3 Jean-Baptiste Faure 2018-03-13 13:14:43 UTC
Not reproducible with version 6.0.3.0+ built at home under Ubuntu 16.04 x86-64.

Please could you attach a test file showing the problem. It should have a section and, if you cannot write outside the section, no paragraph mark outside the section.

Status set to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 4 Daniele 2018-03-13 14:01:29 UTC
Created attachment 140613 [details]
Section
Comment 5 Daniele 2018-03-13 14:03:25 UTC
I am so sorry for what I wrote as what actually happens is the opposite. If I insert a section (and then write in it) writer gives me automatically the cursor underneath the section, allowing me to keep writing underneath it. On the other hand, if I write the text and then highlight it and insert a section I cannot keep writing underneath the section in a new paragraph.
Comment 6 Dieter 2018-03-13 14:30:59 UTC
I confirm this with

Version: 5.4.6.1 (x64)
Build-ID: 7d6c666f03cf1f0a0c2c51a17c0f67a8d5a8012b
CPU-Threads: 4; BS: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

Steps to reproduce
1. Open writer and write some text
2. Mark all the text => insert => section

Result: There is no formatting mark below the section

Perhaps it's a duplicatre of bug 71495, but I don't have the time to check this in detail
Comment 7 Xisco Faulí 2018-03-14 08:57:39 UTC
Also reproduced in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 8 Daniele 2018-04-05 18:58:44 UTC
Still present in LO 6.0.3
Comment 9 Jean-Baptiste Faure 2018-04-07 11:42:29 UTC
It's not a bug, the solution is the same for a section as it is for a table: move the cursor at the end of the section, then hit alt+Enter. It works the same if you want insert a paragraph before the section.

https://help.libreoffice.org/latest/en-US/text/swriter/guide/sections.html?&DbPAR=WRITER&System=WIN

Closing as NotABug.

Best regards. JBF