Bug 116539 - FILESAVE: Strange bullets appear after RT
Summary: FILESAVE: Strange bullets appear after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: imageHandling-regressions
  Show dependency treegraph
 
Reported: 2018-03-21 12:15 UTC by Xisco Faulí
Modified: 2018-05-28 09:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sampel document (1.03 MB, application/vnd.ms-powerpoint)
2018-03-21 12:15 UTC, Xisco Faulí
Details
screenshot after RT (24.66 KB, image/png)
2018-03-21 12:16 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-03-21 12:15:46 UTC
Created attachment 140789 [details]
sampel document

Steps to reproduce:
1. Open attached document
2. Save it as .PPT
3. Open the new created file

Observed behaviour: Star bullets are lost

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 234d0368c823eb1a74e973e051ac522e6b86e833
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-03-21 12:16:46 UTC
Created attachment 140791 [details]
screenshot after RT
Comment 2 Xisco Faulí 2018-03-21 12:18:41 UTC
Regression introduced by:

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-02-17 18:10:11 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-02-18 11:48:13 +0100
commit	7273bb3534264867e818c13baffcdf3862189cd2 (patch)
tree	88a90410fe4afa9f487d8854b898fbb6733c3ad7
parent	82ab7a1559170889c5647a04dc3e85edc38a4e0f (diff)
in numbering use "GraphicBitmap" property for image transport

Bisected with: bibisect-linux64-6.1

Adding Cc: to Tomaž Vajngerl
Comment 3 Tomaz Vajngerl 2018-05-10 02:26:22 UTC
I don't see any star bullets in the sample document when I open (the first time) the sample document with 6.0 or 6.1.

Tried to save the ppt document and open again and it seems the result is the same. Could it be that this was solved with tdf#116272 ?
Comment 4 Xisco Faulí 2018-05-28 09:59:41 UTC
(In reply to Tomaz Vajngerl from comment #3)
> I don't see any star bullets in the sample document when I open (the first
> time) the sample document with 6.0 or 6.1.
> 
> Tried to save the ppt document and open again and it seems the result is the
> same. Could it be that this was solved with tdf#116272 ?

Indeed it was solved with https://cgit.freedesktop.org/libreoffice/core/commit/?id=711c2e49dd3c51877263148267344e2eb4ca7c0d.
My description was incorrect ( Probably a copy-paste problem ). I've double checked it an the problem is that before your commit some objects were displayed after the RT ( as displayed on the screenshot ) but it's fixed now. Thank you very much for fixing this.

Verified in

Version: 6.1.0.0.beta1+
Build ID: da49f4aeb8d5e9a7d2cba8855d911e7cc1d2f1e2
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded