Bug 116544 - EDITING: Inserting Photo Album that includes .MOV causes Crash
Summary: EDITING: Inserting Photo Album that includes .MOV causes Crash
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.0.4 target:5.4.7
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-03-21 16:23 UTC by Daniel Oakey
Modified: 2018-04-05 14:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Oakey 2018-03-21 16:23:30 UTC
Steps to Reproduce Bug:

1. Insert > Media > Photo Album
2. Click Add
3. Navigate to a .mov file and double click it
4. Click Insert Slides

Example: https://i.imgur.com/2AiqpHg.gif

It would be nice if the "Create Photo Album" function would support video files in the same way it supports images and animated GIFs.
Comment 1 Xisco Faulí 2018-03-22 13:15:17 UTC
I didn't have any .mov file at hand. Renaming any other file to .mov does the trick as well..

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 234d0368c823eb1a74e973e051ac522e6b86e833
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

but not in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

it need to be bisected with bibisect-win32-5.1
Comment 2 Buovjaga 2018-03-23 15:33:51 UTC
It crashes already in 5.0, but only as you exit LibreOffice. I bisected to:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=070141b854c7731aa44ccf6ce446802ad8653697

commit	070141b854c7731aa44ccf6ce446802ad8653697 (patch)
tree	e02bcc9af2910a8a8ba3c2628e2f4707208d0e9f
parent	82d573e8bf97193c032ca9631d33fa39bbd12638 (diff)
tdf#64573: Add captions to Photo Album
Creates a rectangular text area with following attributes-
Color-Black
Transparency-20%
Alignment-Bottom
Default Text-Click to add Title

Change-Id: Ifb75c57fd19d41635fd4e397cbfe2b8a65975eb6
Reviewed-on: https://gerrit.libreoffice.org/14517

Rishabh is no longer working on LibO, so no use adding him to CC. Maybe I could bisect the immediate crash as well.
Comment 3 Buovjaga 2018-03-23 16:23:25 UTC
The immediate crash upon inserting any non-image binary file is supposedly:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=22aeb2cdddab4b8b903126d651751838e63cbf73

commit	22aeb2cdddab4b8b903126d651751838e63cbf73 (patch)
tree	ef0ddb8e945c8b17db6a2bc6e888e613653ba1d9
parent	8729504f93c8b59cb2fd6145a1f02987d5fcdb47 (diff)
bmp failure not detected as such because of svg fallback test
I thought it was suspicious that everything was a pass

Change-Id: I10b98cc19d2e23bd5d518113785aeca3a0ea346a
Reviewed-on: https://gerrit.libreoffice.org/18662

Adding Caolán to CC.
Comment 4 Caolán McNamara 2018-03-25 16:34:24 UTC
not much to do with me, but its an unhandled exception so easy to make not crash
Comment 5 Commit Notification 2018-03-25 19:36:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1a600d6ed6578feda6e66d1e4f4f784818c308a6

tdf#116544 crash on unhandled IllegalArgument exception

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Buovjaga 2018-03-26 10:02:19 UTC
No longer crashes.

Daniel: if you want to pitch the video file support idea to the design team, create a new report and set severity to enhancement.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: add7a962bc33b3c1f2252a9920bebf324df688de
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 26th 2018
Comment 7 Commit Notification 2018-04-05 14:12:09 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=944b882d3296b33f4b33b8ef3e33d020ed428732&h=libreoffice-6-0

tdf#116544 crash on unhandled IllegalArgument exception

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-04-05 14:47:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=92a0181d96a43a7a0449f400d38299097e864617&h=libreoffice-5-4

tdf#116544 crash on unhandled IllegalArgument exception

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.