Bug 116610 - TABLE FORMATTING: Paragraph alignment is not persistent
Summary: TABLE FORMATTING: Paragraph alignment is not persistent
Status: RESOLVED DUPLICATE of bug 115573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-24 18:30 UTC by zyklon87
Modified: 2018-04-02 12:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen cast example (1.11 MB, video/webm)
2018-03-27 22:50 UTC, zyklon87
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zyklon87 2018-03-24 18:30:53 UTC
Description:
# First bug

I have a customized, empty base-document with (among other changes) the text body font set to Linux Libertine – table styles inherit that.

So I create a new table and enter some words. Now what I see is, that these contents have the correct style “column content”, but for some reason the Liberation Serif font. I can select that text and re-apply the style “column content” – now, the text gets the correct font(?), which is Linux Libertine.

# Second bug

Then I apply some direct formatting – for example making the top row center-aligned. When I now edit the table (this bug doesn’t occur after all actions, but for example if I delete one column), this direct formatting gets deleted. On my other machine, also the above mentioned style gets set-back, but somehow not on the current machine. On both machines I run Fedora 27 with the latest LO Flatpak.

Steps to Reproduce:
.

Actual Results:  
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:
.


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Dieter Praas 2018-03-25 15:51:58 UTC
I'm not 100% sure, but I think your issue is about table formatting but not about table styles, because it is actual not possible to change the predefined table styles or to create an new table style (see table styles in the sidebar).
Comment 2 zyklon87 2018-03-26 23:02:24 UTC
I’m not that deep into your nomenclature, sorry. It’s just that my fonts and my direct formatting get overwritten… ;)
Comment 3 Dieter Praas 2018-03-27 07:03:27 UTC
> So I create a new table and enter some words. Now what I see is, that these
> contents have the correct style “column content”, but for some reason the
> Liberation Serif font. I can select that text and re-apply the style “column
> content” – now, the text gets the correct font(?), which is Linux Libertine.

Please have a look, if it is the same issue as described in bug 115465
Comment 4 Dieter Praas 2018-03-27 07:05:20 UTC
> # Second bug
> 
> Then I apply some direct formatting – for example making the top row
> center-aligned. When I now edit the table (this bug doesn’t occur after all
> actions, but for example if I delete one column), this direct formatting
> gets deleted. On my other machine, also the above mentioned style gets
> set-back, but somehow not on the current machine. On both machines I run
> Fedora 27 with the latest LO Flatpak.

Is it possible to give some more detailed steps?
Comment 5 zyklon87 2018-03-27 22:50:05 UTC
Yeah, is about the same. Still, I already created a screencast if you’re interested:
Comment 6 zyklon87 2018-03-27 22:50:47 UTC
Created attachment 140928 [details]
Screen cast example
Comment 7 Dieter Praas 2018-03-28 16:02:04 UTC
Since the first bug is a duplicate of bug 115465 I concentrate on the second bug => I changed the bug summary.

I couldn't reproduce it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 9d75bfcfaef97b247b3b6cd346eb27e02ae7b010
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-19_06:25:17
Locale: de-DE (de_DE); Calc: CL

But I could see in the sidebar in your screencast (from 0:50 on), that the alignment in "Absatz" immediately changes back to right-Button, although the text is still centered. So I think here is the problem.
Comment 8 raal 2018-04-02 12:51:26 UTC
(In reply to Dieter Praas from comment #7)
> Since the first bug is a duplicate of bug 115465 I concentrate on the second
> bug => I changed the bug summary.
> 


second bug is duplicate of bug 115573

*** This bug has been marked as a duplicate of bug 115573 ***