Bug 116633 - Values in filtered columns with dates shown incorrectly
Summary: Values in filtered columns with dates shown incorrectly
Status: RESOLVED DUPLICATE of bug 139809
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 120223 (view as bug list)
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2018-03-26 11:11 UTC by Marina Latini (SUSE)
Modified: 2021-01-26 13:17 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
test-file (14.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-03-26 11:12 UTC, Marina Latini (SUSE)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini (SUSE) 2018-03-26 11:11:52 UTC
Description:
While filtering multiple columns with date the values disappeared when reopening the file.

Steps to Reproduce:
1. Open the attached file
2. Filter the data on column A
3. Apply a second filter on column B
4. Save the file
5. Close the document
6. Reopen the file
7. Try to modify the filters

Actual Results:  
The filters hide all the values and show only the previous filtered ones.

Expected Results:
All the available dates can be selected/deselected


Reproducible: Always


User Profile Reset: Yes



Additional Info:
The error occurs only with columns with dates.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Marina Latini (SUSE) 2018-03-26 11:12:36 UTC
Created attachment 140884 [details]
test-file
Comment 2 Marina Latini (SUSE) 2018-03-26 12:28:00 UTC
first affected:
Versione: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
Thread CPU: 4; Versione SO: Linux 4.15; Resa interfaccia: predefinito; VCL: gtk2; Motore layout: nuovo; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group

affected but with a different behaviour (with this version while filtering on column A (try disable the April month) all the dates disappear):
Versione: 5.2.7.2
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
Thread CPU: 4; Versione SO: Linux 4.15; Resa interfaccia: predefinito; VCL: gtk2; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group


works with:
Versione: 5.3.0.1
Build ID: 3b800451b1d0c48045de03b5b3c7bbbac87f20d9
Thread CPU: 4; Versione SO: Linux 4.15; Resa interfaccia: predefinito; VCL: gtk2; Layout Engine: new; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group
Comment 3 m.a.riosv 2018-03-26 12:28:32 UTC
Repro
Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-ZA (es_ES); Calc:
Comment 4 Marina Latini (SUSE) 2018-03-26 15:33:06 UTC
450ba491a76b0e9caea9e8ad197339bc7eebb9af is the first bad commit
commit 450ba491a76b0e9caea9e8ad197339bc7eebb9af
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Feb 16 03:14:15 2017 +0100

    source sha:42e472b5870278058537d43d03d457dc80b16166
    
    source sha:42e472b5870278058537d43d03d457dc80b16166

:040000 040000 b1f1c35677e2ff494f223c6a2c6608a0d5a9aeb4 dd15c710f82ca26c02e3be68efc6906fe2610396 M      instdir



# bad: [b5b34aafb02f9070db485080b35ce0179c38b941] source sha:328f3e7e4c67bf2e09a56f199a4332f1b1fe3b11
# good: [f04172d4ac1553877deea87d267307ad3eb1c99b] source sha:4136757b4e51c4e6f7cb4132c95538a7f831ef2c
git bisect start 'master' 'oldest'
# bad: [6a71512f3c2d554422bbd939e7740cf3ea128bf2] source sha:64b68e98d215f98f72fd6493b62517ab9984a8d2
git bisect bad 6a71512f3c2d554422bbd939e7740cf3ea128bf2
# good: [103dcb92b5c7ec253b78108b207fd300a82d0f8e] source sha:d685b030aa0d7aa25d9666cd6857b7cb917e297c
git bisect good 103dcb92b5c7ec253b78108b207fd300a82d0f8e
# bad: [e848094fcd19daedf0ee9b0b7be1a5ee94e75523] source sha:a296a69c984b17cfbcd249cf6bdc191d08dff2a6
git bisect bad e848094fcd19daedf0ee9b0b7be1a5ee94e75523
# good: [136384d71ee9f6b8adcf52866fbe6528840f0684] source sha:86e99f84619e9b1f9063b1c31081e51344f1cf54
git bisect good 136384d71ee9f6b8adcf52866fbe6528840f0684
# good: [55c0be7502024a5a85c09580fa1a9f9f0147d3f2] source sha:4d009bb402e465937dccd19351c96615beaab44b
git bisect good 55c0be7502024a5a85c09580fa1a9f9f0147d3f2
# good: [29fb1300de839e2d8f52665df461ff923aebebbc] source sha:b12823aa81003e80372bd89db79bd6ba8e032a95
git bisect good 29fb1300de839e2d8f52665df461ff923aebebbc
# bad: [deba50d6ec8437caf0543f90a6db1eabed0dc293] source sha:eb9b9c28ed32cacb5ed0410875af2ec03345fbf9
git bisect bad deba50d6ec8437caf0543f90a6db1eabed0dc293
# bad: [543c0fa728372b6fa2ddd979b7b9887ca5114c29] source sha:d92ce4a6a57ffe180430dd8387c8aa393be673ba
git bisect bad 543c0fa728372b6fa2ddd979b7b9887ca5114c29
# bad: [450ba491a76b0e9caea9e8ad197339bc7eebb9af] source sha:42e472b5870278058537d43d03d457dc80b16166
git bisect bad 450ba491a76b0e9caea9e8ad197339bc7eebb9af
# good: [e6ec48772202a694683a51fa2f06bdbc7fb07431] source sha:e95765027e183728cf830ee0c120df29ce04c0d3
git bisect good e6ec48772202a694683a51fa2f06bdbc7fb07431
# good: [64d8dd1a8ea8e3142c797b2f07aa602514a29593] source sha:750ca7dec9491e924905b402a662aab6ecc00387
git bisect good 64d8dd1a8ea8e3142c797b2f07aa602514a29593
# good: [8a2153c2c2733c51e6168ff88e9749ccd126a8ee] source sha:af42aab836626fdf7b29921dff5d344a8b0e47c6
git bisect good 8a2153c2c2733c51e6168ff88e9749ccd126a8ee
# good: [98bed40aad16206f2d304a40c1a539067b0903c4] source sha:5f33745c1d6750126e53a02b2a95355a3e5b16a0
git bisect good 98bed40aad16206f2d304a40c1a539067b0903c4
# first bad commit: [450ba491a76b0e9caea9e8ad197339bc7eebb9af] source sha:42e472b5870278058537d43d03d457dc80b16166
Comment 5 Marina Latini (SUSE) 2018-03-26 15:38:47 UTC
the first affected version is 5.3.3.2
Comment 6 Marina Latini (SUSE) 2018-04-27 10:14:52 UTC
Repro with:

Version: 6.1.0.0.alpha1
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 4; OS: Linux 4.16; UI render: default; VCL: gtk2; 
Locale: it-IT (it_IT.UTF-8); Calc: group
Comment 7 V Stuart Foote 2018-04-30 19:00:34 UTC
@Kohei, could you have a look at this given the bibisect result.

Is the Advanced filter handling of Time colliding with the checklistmenu Auto Filter handling of Dates?

https://cgit.freedesktop.org/libreoffice/core/commit/?id=42e472b5870278058537d43d03d457dc80b16166
Comment 8 Aron Budea 2018-10-01 00:51:56 UTC
*** Bug 120223 has been marked as a duplicate of this bug. ***
Comment 9 Aron Budea 2018-10-01 01:00:20 UTC
To summarize, the following commit, identified by Marina in comment 4 causes autofilter to not work on dates (bug 106214). This was backported to 5.2, hence the behavior of 5.2.7.2 mentioned in comment 2.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=42e472b5870278058537d43d03d457dc80b16166
author		Kohei Yoshida <kohei.yoshida@collabora.com>	2017-01-30 22:01:45 -0500
committer	Kohei Yoshida <libreoffice@kohei.us>	2017-02-02 05:01:53 +0000

"tdf#105629: Let's move the advanced-filter specific stuff ..."


The following commit fixes autofilter on dates, and results in the current behavior.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b3d498755238cb0d9a7a3e33b6070c1e4c0e3482
author		Markus Mohrhard <markus.mohrhard@googlemail.com>	2017-03-26 22:50:18 +0200
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2017-03-27 00:51:54 +0000

"handle date autofilter entries correctly, tdf#106214"
Comment 10 Marina Latini (SUSE) 2018-12-21 09:16:39 UTC
Repro with:
Versione: 6.2.0.1 (x64)
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Thread CPU: 4; SO: Windows 10.0; Resa interfaccia: GL; VCL: win; 
Versione locale: de-DE (en_US); UI-Language: it-IT
Calc: threaded
Comment 11 b. 2020-05-21 19:26:21 UTC
repro - still buggy with: 7.0.0.0.a1+

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc:
Comment 12 Balázs Varga 2021-01-26 13:17:09 UTC

*** This bug has been marked as a duplicate of bug 139809 ***