Download it now!
Bug 116798 - Impress crashes when deleting slides
Summary: Impress crashes when deleting slides
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: wantBacktrace
Depends on:
Blocks:
 
Reported: 2018-04-04 14:28 UTC by Frederic Parrenin
Modified: 2018-06-21 13:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["sdr::contact::ViewObjectContact::getObjectRange()"]


Attachments
sample (1.46 MB, application/vnd.oasis.opendocument.presentation)
2018-04-05 18:02 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2018-04-04 14:28:09 UTC
Steps to reproduce:
- open the following .odp file:
https://mycore.core-cloud.net/index.php/s/7f0dIa5aYgyVrtd
- on the left side pane, right-click on the second slide and choose "delete slide"
- right-click again on the second slide and choose "delete slide"
=> CRASH
Comment 1 Frederic Parrenin 2018-04-04 14:32:09 UTC
Actually, just resaving the file causes Impress to crash.
Comment 2 Julien Nabet 2018-04-04 16:50:31 UTC
On pc Debian x86-64 with LO Debian package, I don't reproduce this with 6.0.2.1

For the test, could you give a try to https://wiki.documentfoundation.org/QA/FirstSteps ?
Comment 3 Frederic Parrenin 2018-04-04 16:59:21 UTC
This is a windows only bug.
Comment 4 MM 2018-04-04 21:14:01 UTC
On windows 7 x64 with Version: 6.0.3.2 (x64)
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 3; OS: Windows 6.1; UI render: default

when deleting 3 slides it hangs for a couple of minutes taking all processortime. After some time it returns to normal and you can work with impress again. After that, delete a few more slides and it'll crash.

But you can get the hang and crash also when enabling the 'slide sorter'.
Just wait for a view minutes and just after the slides are shown, impress crashes.

Or scroll the slide notes down. Wait a bit and scroll some more.
Comment 5 Xisco Faulí 2018-04-05 18:02:24 UTC
Created attachment 141147 [details]
sample
Comment 6 Xisco Faulí 2018-04-05 18:08:34 UTC
I can reproduce it in

Versión: 6.0.1.1
Id. de compilación: 60bfb1526849283ce2491346ed2aa51c465abfe6
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

STR:
1. Open the file
2. delete slides 2, 3, 4, 5
3. use undo until all the slides are added back
4. Use redo until all the slides are removed
5. Repeat 3 and 4

-> Crash
Comment 7 Xisco Faulí 2018-04-05 18:13:01 UTC
Surprisingly, I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 751191ed2d7d6af6eddc3d738e8c45b0a2ab2572
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-21_23:24:05
Locale: es-ES (es_ES); Calc: group

Can anyone try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
Comment 8 Frederic Parrenin 2018-04-06 09:33:58 UTC
Strange, now I cannot reproduce anymore, even with version 6.0.2.
Comment 9 Xisco Faulí 2018-04-06 10:42:34 UTC
(In reply to Frederic Parrenin from comment #8)
> Strange, now I cannot reproduce anymore, even with version 6.0.2.

Do you reproduce the steps from comment 6 ?
Comment 10 Frederic Parrenin 2018-04-06 11:18:52 UTC
Yes, I have tried the repro from comment 6 as well.
Comment 11 Telesto 2018-04-07 16:41:14 UTC
I can reproduce a crash using the file.. However different steps: see bug 116803
Comment 12 Xisco Faulí 2018-06-21 13:27:55 UTC
I can no longer reproduce it in

Versión: 6.1.0.0.beta2
Id. de compilación: 0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

Closing as RESOLVED WORKSFORME

Please, set it back to NEW if it's still reproducible in a master build from http://dev-builds.libreoffice.org/daily/master/