Bug Hunting Session
Bug 116847 - image style - aspect ratio greyed out?
Summary: image style - aspect ratio greyed out?
Status: RESOLVED DUPLICATE of bug 40469
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-06 11:25 UTC by tariq.rashid50
Modified: 2018-04-09 12:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot showing greyed out "keep ratio" (103.96 KB, image/jpeg)
2018-04-06 11:26 UTC, tariq.rashid50
Details
lo60 and lo61 "aspect ratio" problem (684.93 KB, image/png)
2018-04-08 20:18 UTC, tariq.rashid50
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tariq.rashid50 2018-04-06 11:25:53 UTC
Description:
I'm trying to create a style that applies to images and changes their width to a set % of the paragraph, and keeps the vertical height in proportion maintaining aspect ratio

Changing the border in an image style works - rescaling the image as part of the image style doesn't work - see image below which shows "keep aspect ration" greed out.

Steps to Reproduce:
1. insert images into doc
2. edit frame image style try to set width to be a % of the paragraph area
3. try to set "Keep ratio" so image is not distorted

Actual Results:  
4. "Keep ratio" is greyed out for no apparent reason. No documentation to explain why.

Expected Results:
Expect "Keep ratio" not to be. greyed out so that when image style is applied to images, they are scaled according to the set % and the height is adjusted to maintain aspect ratio.


Reproducible: Always


User Profile Reset: No



Additional Info:
thorough search of docs/wiki/google shows no explanation.

see attached image for screenshot


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1 Safari/605.1.15
Comment 1 tariq.rashid50 2018-04-06 11:26:24 UTC
Created attachment 141166 [details]
screenshot showing greyed out "keep ratio"
Comment 2 Dieter Praas 2018-04-08 19:25:36 UTC
Can't reproduce it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 2325f9ac789cd12e5ecc9d239baf2558e1d678bb
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-05_00:37:47
Locale: en-US (de_DE); Calc: CL
Comment 3 tariq.rashid50 2018-04-08 20:18:54 UTC
Created attachment 141211 [details]
lo60 and lo61 "aspect ratio" problem
Comment 4 tariq.rashid50 2018-04-08 20:21:35 UTC
see uploaded image which shows the bug reproduced for both LibreOffice 6.0.3.2 and 6.1.0.0

To demonstrate the image style does work for there tasks - it is shown working applying a coloured border to every image with that style.

However the image scaling options are still buggy in both LO60 and LO61.

I've searched google and the official docs and found no answers.
Comment 5 Dieter Praas 2018-04-08 20:27:47 UTC
You can't confirm your own bugs. So we have to change the status back to UNCONFIRMED unless somebody else is able to reproduce the bug.
Comment 6 raal 2018-04-09 12:13:20 UTC

*** This bug has been marked as a duplicate of bug 40469 ***