Download it now!
Bug 116908 - LibreOffice saves CSVs with \n line endings, in violation of RFC-4180
Summary: LibreOffice saves CSVs with \n line endings, in violation of RFC-4180
Status: RESOLVED DUPLICATE of bug 59041
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.4.5.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-09 20:49 UTC by Richard Simões
Modified: 2018-04-09 22:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Simões 2018-04-09 20:49:49 UTC
Description:
CSV files saved by Calc on *nix systems save with line feeds all by their lonesome. From https://tools.ietf.org/html/rfc4180:

"Each record is located on a separate line, delimited by a line break (CRLF)."

Steps to Reproduce:
1. Enter some data in a new Calc document, or open any spreadsheet containing static data on a single sheet.
2. Save as CSV.

Actual Results:  
The resulting CSV file's line breaks consist of LF characters.

Expected Results:
The resulting CSV file's line breaks consist of CRLF sequences.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36
Comment 1 Regina Henschel 2018-04-09 22:34:22 UTC
From the same source and same paragraph there,
"While there are various specifications and implementations for the
   CSV format (for ex. [4], [5], [6] and [7]), there is no formal
   specification in existence, which allows for a wide variety of
   interpretations of CSV files.  "

But you are right, that there should be an additional option in the save as dialog to choose the record delimiter. Such wish is already tracked in bug 59041.

*** This bug has been marked as a duplicate of bug 59041 ***