Bug Hunting Session
Bug 116951 - LibreOffice crashed when inserted "−" (minus, U+2212) character on Gnome on Wayland
Summary: LibreOffice crashed when inserted "−" (minus, U+2212) character on Gnome on W...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.1.0 target:6.0.5
Keywords:
: 118159 (view as bug list)
Depends on:
Blocks: Wayland
  Show dependency treegraph
 
Reported: 2018-04-11 22:07 UTC by Aleš Kvapil
Modified: 2018-06-18 15:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleš Kvapil 2018-04-11 22:07:49 UTC
Description:
- Open Impress (v 5.4.6 or 6 tested) on Gnome (Arch Linux) on Wayland (Xorg works perfectly)
- It is openned under general LibreOffice icon, not under Impress icon (only on Wayland - this bug is already addressed and in 6.0 still not solved)
- Choose some template (I used "DNA"), create something, save
- Click to some text field
- Ctrl (hold) + Shift (hold) + u2212 (and finally release Ctrl + Shift) => should insert a minus
- Impress crashed
- Click not to restore
- Confirm not to restore, confirm not to restore
- See Writer is openned instead of Impress? What the..

Actual Results:  
general LibreOffice icon, crash, different component after crash

Expected Results:
Impress icon, no crash, Impress after restart


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Caolán McNamara 2018-04-19 08:06:00 UTC
That input works fine for me, no crash. Is there a backtrace ?

(Icon is separate issue and cannot be fixed via current gtk apis https://bugzilla.gnome.org/show_bug.cgi?id=779143)
Comment 2 Caolán McNamara 2018-04-19 18:56:15 UTC
Got a fedora 28 report that is similar, so maybe something new going on https://bugzilla.redhat.com/show_bug.cgi?id=1569331
Comment 3 Commit Notification 2018-04-19 20:12:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4a01820ae094ef2d4ec2196334120600b1c9621

Related: tdf#116951 rhbz#1569331 end should be in terms of unicode chars

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Buovjaga 2018-04-24 06:06:20 UTC
No crash for me under a Wayland session with a recent build.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 14184060bd2249a492ea44d36463914c421e6ce5
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 23rd 2018
Comment 5 Commit Notification 2018-04-24 18:05:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=697ebd15d646e41bb69726f7b438ebbfaff141b0

Resolves: tdf#116951 rhbz#1569331 start is G_MAXINT

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2018-04-24 19:19:18 UTC
sberg can reproduce and reports that my (second) effort at this works.
Comment 7 Commit Notification 2018-04-25 07:58:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d6fc3c88902ca74f934960e7600df99605dea48

Related: tdf#116951 use same pattern for gtk2

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-04-26 13:47:20 UTC
@Caolán, should it be backported to LibreOffice 6.0 ?
Comment 9 Commit Notification 2018-04-26 14:18:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7d8a6ffae387a2698b07a8841e09ca3ed0bb000&h=libreoffice-6-0

Resolves: tdf#116951 rhbz#1569331 start is G_MAXINT

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2018-06-18 15:23:18 UTC
*** Bug 118159 has been marked as a duplicate of this bug. ***