Download it now!
Bug 117034 - CRASH: special characters dialog - right click Favorite characters (gtk3)
Summary: CRASH: special characters dialog - right click Favorite characters (gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.1.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2018-04-16 09:19 UTC by Xisco Faulí
Modified: 2018-04-18 15:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-04-16 09:19:41 UTC
Steps to reproduce:1
1. Open Writer
2. Open Special Characters Dialog
3. Right click on any favourite character

-> CRASH

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 24a57e2b854a1b8b3b8533ac72a6614ee29e374a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2018-04-16 09:21:45 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2018-03-22 13:41:50 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-03-30 14:32:12 +0200
commit	374599f8c26713905a310673d2b429083321186a (patch)
tree	2ee4be182670b2ca9396a5f42d4122bed806a3ba
parent	2d3a5e81e9730c1190f8592f85f5b99b6d4587ef (diff)
weld SvxCharacterMap dialog
and SmSymDefineDialog

There's a whole bunch of interrelated stuff which needs to work at the same
time.

Bisected with: bibisect-linux64-6.1

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2018-04-16 12:59:10 UTC
doesn't crash for me, but I bet its a older version of gtk3 than I have and its the other ifdef, what's the version of gtk3 ?
Comment 3 Xisco Faulí 2018-04-16 13:20:40 UTC
(In reply to Caolán McNamara from comment #2)
> doesn't crash for me, but I bet its a older version of gtk3 than I have and
> its the other ifdef, what's the version of gtk3 ?

I have 3.18.9-1ubuntu3.3  because I use linux mint, which is based on ubuntu 16.04 LTS
Comment 4 Commit Notification 2018-04-16 19:52:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=00c317da4b50db8793c4d7a2e70084b716d75735

tdf#117034 right click crash

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2018-04-16 19:53:45 UTC
I imagine that was the problem
Comment 6 Xisco Faulí 2018-04-17 10:48:42 UTC
Still crashing here

Version: 6.1.0.0.alpha0+
Build ID: 3564b46992fc30e212011c19043a2553178ccbca
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

This is what I get in the console:

/home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/soffice.bin: symbol lookup error: /home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/libvclplug_gtk3lo.so: undefined symbol: gtk_menu_popup_at_rect
Comment 7 Maxim Monastirsky 2018-04-17 11:10:19 UTC
(In reply to Xisco Faulí from comment #6)
> This is what I get in the console:
> 
> /home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/soffice.bin:
> symbol lookup error:
> /home/xisco/bibisect/bibisect-linux64-6.1/instdir/program/libvclplug_gtk3lo.
> so: undefined symbol: gtk_menu_popup_at_rect
Sounds like the bibisect repo was built with a newer gtk3. Any chance you could try with your own build?
Comment 8 Caolán McNamara 2018-04-17 13:06:58 UTC
if I add a gtk_check_version check that might help
Comment 9 Commit Notification 2018-04-17 19:41:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=42f5a0fbbfe91827fdc0a27525e8cd8938871db2

tdf#117034 check for runtime version check gtk_menu_popup_at_rect

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2018-04-18 15:13:50 UTC
No longer crashes in

Version: 6.1.0.0.alpha0+
Build ID: b07e8a7e16ba69e822a309ec280d1987f90021a3
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Caolán, I think you can close this one one!
Thanks for fixing it!