Bug Hunting Session
Bug 117036 - Copy/paste rows overwrites existing rows (libreoffice Calc)
Summary: Copy/paste rows overwrites existing rows (libreoffice Calc)
Status: RESOLVED DUPLICATE of bug 39936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-16 12:00 UTC by sverre48
Modified: 2018-04-17 07:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sverre48 2018-04-16 12:00:17 UTC
Description:
In windows excel it is a very common function to copy or cut a set of rows and paste it in the excel document. Using Libreoffice calc this paste would overwrite existing information in affected rows.

This is a major functionality flaw in using libreoffice calc.

So I hope this paste row(s) could be mde to reflect the MS excel behaviour 
Insert copied cells/rows

Steps to Reproduce:
1.Open an excel document using libreoffice calc (say .xslx)
2.Copy or cut a set of rows
3.Paste it somewhere in the document

Actual Results:  
Step 3 overwrites existing cells/rows

Expected Results:
Insert/copied the rows as new set of rows - with no overwrite/replacement


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36
Comment 1 m.a.riosv 2018-04-16 14:58:01 UTC
Select the row, click on the select row (not in the row number) without release the mouse use [Ctrl+Alt] to copy+insert and [Shift+Alt] to move+insert.
Comment 2 Timur 2018-04-17 07:44:36 UTC
Miguel's workaround is for mouse drag. 
And description looks like a duplicate of Bug 39936.

*** This bug has been marked as a duplicate of bug 39936 ***