Bug 117105 - Libreoffice 6.0.2 crashes when choosing "Tools" > "Options" and secring.gpg is present in Linux
Summary: Libreoffice 6.0.2 crashes when choosing "Tools" > "Options" and secring.gpg i...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.5
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-19 12:41 UTC by Shenden
Modified: 2018-05-08 11:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace log (14.62 KB, text/x-log)
2018-04-19 13:51 UTC, Shenden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shenden 2018-04-19 12:41:22 UTC
Description:
Libreoffice (writer, calc, ...) crashes as soon as "Tools" > "Options" is clicked on some linux distributions, for example Slackware 14.2 and CentOS 7.4, when the file secring.gpg exists in the .gnupg folder. When secring.gpg is 0 bytes it does not crash. It probably has to to with the new encryption feature.

Steps to Reproduce:
1. Open Libreoffice Writer or Calc or Draw on (some) Linux Distributions
2. Choose Tools and then Options
3.

Actual Results:  
Libreoffice crashes and reopens, asking whether it shoud to restore the document.

Expected Results:
the Options window should be opened


Reproducible: Always


User Profile Reset: Yes



Additional Info:
64 bit. 


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2018-04-19 13:31:08 UTC
I have the file in .gnupg and it doesn't crash for me

-rw------- 1 xisco xisco 11457 abr  7 18:06 secring.gpg

If possible, please follow the instructions provided at this link < https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux >. and submit a backtrace. That way a developer can look into the underlying reason of the crash.
Comment 2 Shenden 2018-04-19 13:51:06 UTC
Created attachment 141488 [details]
Backtrace log

I attached the Backtrace log. I found the lines:

Thread 1 "soffice.bin" received signal SIGSEGV, Segmentation fault.
0x00007fffe208b5f7 in ?? () from /usr/lib64/../lib64/libgpgme.so.11

Thanks for your quick reply.

This is on Slackware 14.2 64 bit.
Comment 3 Xisco Faulí 2018-04-20 07:35:00 UTC
@Caolán, this crash is happening in CentOS 7.4.
Is it something red hat takes care of as well?
Comment 4 Caolán McNamara 2018-04-20 09:52:28 UTC
because the backtrace mentions /usr/lib64/libreoffice/program/libgpgmepp.so.6 I can see that the system gpgmepp is being used rather than the bundled one. Is this build from libreoffice.org or a self build or somewhere else ?
Comment 5 Shenden 2018-04-20 16:53:51 UTC
The official package of Libreoffice in CentOS is much older and does not exhibit this behaviour, it occured when I downloaded the rpms from Libreoffice.org, version 6.0.2, and installed those instead of CentOS's libreoffice packages. With 6.0.3 this seems to have been solved on CentOS.

The Slackware build of Libreoffice, version 6.0.2, is semi-offical, it is build by one of the main contributors to Slackware. I would guess that shared libraries are used wherever possible with that build. I remember also seeing this behaviour on OpenBSD with libreoffice 6.0.x, but I did not report a bug then.
Comment 6 Shenden 2018-04-20 18:43:43 UTC
I now installed LibreOffice 6.0.3 in Slackware 14.2 via building from the official rpms and it works fine. So the issue probably really is connected to builds using system libraries.
Comment 7 Caolán McNamara 2018-05-03 12:12:05 UTC
I see dubious RPATHS for libgpgme and I see that in master sberg has fixed those. Backporting those looks like a good idea.
Comment 8 Commit Notification 2018-05-08 11:50:21 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f7028dd292e22f09cd505b529d93713747ebd6b&h=libreoffice-6-0

Related tdf#117105 fix RPATHS of gpgme and assuan

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2018-05-08 11:51:40 UTC
I reckon that'll fix the underlying rpath related issues