Bug 117126 - Compress image breaks crop
Summary: Compress image breaks crop
Status: RESOLVED DUPLICATE of bug 83734
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Image-Compression Image-Crop Image-DPI
  Show dependency treegraph
 
Reported: 2018-04-20 13:43 UTC by sergio.callegari
Modified: 2019-12-12 22:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (155.47 KB, application/vnd.oasis.opendocument.graphics)
2018-04-21 12:27 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2018-04-20 13:43:44 UTC
Description:
Suppose that you have a jpg image in a presentation slide in impress and that you want to recompress it because your presentation file is too large.
You can achieve this result with the 'compress' function in the context menu for the image. Unfortunately, if the image is cropped, compress often breaks the cropping, resulting in distorted images.

Steps to Reproduce:
See description

Actual Results:  
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: StartModule
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Regina Henschel 2018-04-21 12:11:56 UTC
The same problem was reported in bug 99265. That was resolved duplicate to bug 99286, which is fixed now. But the problem described here still exists. I see it in Version: 6.1.0.0.alpha0+ (x64)
Build ID: 55b9706bea5aa9b654ab39bc7d56339422e17087
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-18_06:02:46
Locale: de-DE (de_DE); Calc: CL

Problem: The original image is reduced in quality and DPI as chosen in the dialog. But the crop values are totally wrong, which results in a distorted image.
Comment 2 Telesto 2018-04-21 12:27:55 UTC
Created attachment 141521 [details]
Sample file
Comment 3 Telesto 2018-04-21 12:33:23 UTC
No repro with
Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (nl_NL)
Comment 4 Telesto 2018-04-21 12:39:54 UTC
This looks like bug 83734 except bug 83734 comment 17 insists on a separate report
Comment 5 Luke 2018-04-22 00:56:45 UTC
Repo in 6.1 master and Version: 4.1.0.1


Removed the "regression" keyword. Also, I fail to see how this is not a dupe of bug 83734. Steps to reproduce are identical, just different components.
Comment 6 QA Administrators 2019-11-01 03:37:02 UTC Comment hidden (obsolete)
Comment 7 sergio.callegari 2019-11-01 07:06:46 UTC
The bug is still present as of LibO 6.3.3.2
Comment 8 Luke 2019-12-12 22:19:06 UTC
I agree with Telesto. This is a dupe of bug 83734. It's a graphics stack issue not impress specific.

*** This bug has been marked as a duplicate of bug 83734 ***