Bug Hunting Session
Bug 117154 - Crash with undo/redo and "!!br0ken!!" text
Summary: Crash with undo/redo and "!!br0ken!!" text
Status: RESOLVED DUPLICATE of bug 117215
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2018-04-22 11:22 UTC by Telesto
Modified: 2018-04-27 18:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["BigPtrArray::Index2Block(unsigned __int64)"]


Attachments
GDB trace of crash with master (17.99 KB, text/plain)
2018-04-23 12:35 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-04-22 11:22:07 UTC
Description:
Crash with undo/redo and "!!br0ken!!" text

Steps to Reproduce:
1. Open attachment 85053 [details] (bug 108124)
2. Open attachment 133424 [details] (bug 107975)
3. Press Arrow down in pic names.odt (last row)
4. Copy the content of Demo.odt (attachment 2)
5. Paste it into pic names.odt at the last paragraph/row
6. Select the "8" images and anchor both to character
7. CTRL+A
8. Hold Paste multiple times (CTRL+V) -> Say 14 pages
9. Undo everything (CTRL-Z)
10. Redo everything (CTRL+Y)
11. Press Undo again (notice missing images etc and a crash at some point)
--
Related: 
1. Open attachment 85053 [details] (bug 108124)
2. Open attachment 133424 [details] (bug 107975)
3. Press Arrow down in pic names.odt (last row)
4. Copy the content of Demo.odt (attachment 2)
5. Paste it into pic names.odt at the last paragraph/row
6. Select the "8" images and anchor both to character
7. CTRL+A
8. Undo everything CTRL+Z
9. Press redo -> !!br0ken!! appears


Actual Results:  
Crash or !!br0ken!!

Expected Results:
No crash and no !!br0ken!!


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: 9c4eaa7b81a40d97fe49b85272b40bfeaaf44f86
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-16_03:31:36
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Buovjaga 2018-04-23 12:35:52 UTC
Created attachment 141557 [details]
GDB trace of crash with master

Repro.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 14184060bd2249a492ea44d36463914c421e6ce5
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 23rd 2018
Comment 2 Xisco Faulí 2018-04-24 23:08:25 UTC
@Telesto, @Buovjaga, could you please try to reproduce it before https://cgit.freedesktop.org/libreoffice/core/commit/?id=14d2255cbd254dea6e87a04f747e7d6d3d54ceb9 ? ie. LibreOffice 5.2...
Comment 3 Buovjaga 2018-04-25 06:06:38 UTC
(In reply to Xisco Faulí from comment #2)
> @Telesto, @Buovjaga, could you please try to reproduce it before
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=14d2255cbd254dea6e87a04f747e7d6d3d54ceb9 ? ie. LibreOffice 5.2...

This has target:6.0.0 target:5.3.5 target:5.4.1 so I tried with 5.3.0 alpha1 (Windows).
It crashed already at 9. Undo everything (CTRL-Z)
In my tests, in step 8 I do not paste "14 pages", but just paste like 3 times.
Comment 4 Xisco Faulí 2018-04-26 13:57:21 UTC
is it possible to get the crash signature?
Comment 5 Buovjaga 2018-04-27 16:51:33 UTC
(In reply to Xisco Faulí from comment #4)
> is it possible to get the crash signature?

I managed to get it on Windows (took 2 tries): http://crashreport.libreoffice.org/stats/crash_details/6382fe3e-ed56-4a93-9b81-a945d483de4d
Comment 6 Xisco Faulí 2018-04-27 17:29:45 UTC
Similar to bug 117215
Comment 7 Telesto 2018-04-27 18:25:15 UTC
I played around a bit not to hard to generate all sorts of crashes, like: 
http://crashreport.libreoffice.org/stats/crash_details/609a8bdf-6f8a-4479-9d89-483b854c2bed

http://crashreport.libreoffice.org/stats/crash_details/98a36fc3-2be5-4c9c-a286-82f589b764f0

But likely all covered by bug 117215.

*** This bug has been marked as a duplicate of bug 117215 ***