Bug 117165 - Update wording of all OOXML import/export filters from "2013" to "2016", e.g. "Microsoft Word 2007-2016 XML" instead of 2013
Summary: Update wording of all OOXML import/export filters from "2013" to "2016", e.g....
Status: RESOLVED DUPLICATE of bug 108894
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-22 17:10 UTC by Gerry
Modified: 2018-04-23 15:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2018-04-22 17:10:34 UTC
Description:
Minor bug: Simple change of wording

Currently the OOXML import and export filters are named "2007-2013", but should be named "2007-2016". This is the case for:

Microsoft Word 2007-2013 XML
Microsoft Word 2007-2013 XML Template
Microsoft Word 2007-2013 XML VBA
Microsoft Excel 2007-2013 XML
Microsoft Excel 2007-2013 Template
Microsoft Powerpoint 2007-2013 XML
Microsoft Powerpoint 2007-2013 XML Template
Microsoft Powerpoint 2007-2013 XML VBA
Microsoft Powerpoint 2007-2013 XML Autoplay
Microsoft Visio 2007-2013

They should be:
Microsoft Word 2007-2016 XML
Microsoft Word 2007-2016 XML Template
Microsoft Word 2007-2016 XML VBA
Microsoft Excel 2007-2016 XML
Microsoft Excel 2007-2016 Template
Microsoft Powerpoint 2007-2016 XML
Microsoft Powerpoint 2007-2016 XML Template
Microsoft Powerpoint 2007-2016 XML VBA
Microsoft Powerpoint 2007-2016 XML Autoplay
Microsoft Visio 2007-2016

Remark: Since Microsoft is going to release Office 2019 this year, it could be even "2007-2019" (if import/export will work for the new MS Office version)




Steps to Reproduce:
You see the outdated wording (e.g. Microsoft Word 2007-2013 XML) if you choose File -> Open and then choose the filter. Or if you choose File -> Save As and then choose the filter.

Actual Results:  
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Buovjaga 2018-04-23 12:45:23 UTC

*** This bug has been marked as a duplicate of bug 108894 ***
Comment 2 Adolfo Jayme 2018-04-23 15:51:35 UTC
Not only one has to take care of mentioning the upcoming 2019, but also the rolling 365 version. What a mess. It’s better to just drop that and mention the OOXML format.
Comment 3 Buovjaga 2018-04-23 15:52:55 UTC
(In reply to Adolfo Jayme from comment #2)
> Not only one has to take care of mentioning the upcoming 2019, but also the
> rolling 365 version. What a mess. It’s better to just drop that and mention
> the OOXML format.

Mike K. said on IRC: "until MSO comes with something new, it would be better to use "Microsoft Word 2007 and later""