Bug Hunting Session
Bug 117186 - Sidebar: Shapes deck should fill the whole sidebar
Summary: Sidebar: Shapes deck should fill the whole sidebar
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: Sidebar-Shapes
  Show dependency treegraph
 
Reported: 2018-04-23 16:09 UTC by Xisco Faulí
Modified: 2018-06-11 12:10 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
how it looks on master (29.44 KB, image/png)
2018-04-23 16:09 UTC, Xisco Faulí
Details
Master (20.02 KB, image/png)
2018-05-01 08:51 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-04-23 16:09:49 UTC
Created attachment 141566 [details]
how it looks on master

The Shades deck was implemented in https://cgit.freedesktop.org/libreoffice/core/commit/?id=ab9708e179762f97bd1a0ee4c0d4b439f1dabfd5 and it was put as experimental in https://cgit.freedesktop.org/libreoffice/core/commit/?id=44216ddbc620a1c05e98dda1f63ed6df0eae5275

Steps to reproduce:
1. Enable experimental mode ( Tools - Options - Advanced )
2. Restart and open Draw
3. Click on Shapes deck

Observed behaviour: The shapes are displayed only on half of the sidebar. See attached image
Comment 1 Xisco Faulí 2018-04-23 16:13:04 UTC
@Heiko, I'm wondering if the shapes deck could be removed from experimental mode once this issue is fixed...
Comment 2 Roman Kuznetsov 2018-04-23 16:27:49 UTC
I made same bug and it was closed as wfm...
Comment 3 Heiko Tietze 2018-04-24 08:37:55 UTC
Jay's comment 1 in bug 102197 "It isnt intended to have a full size height as another section is to be created below it and that is why the sidebar deck is set to experimental."

What he is talking about is the combination with OO shapes from the gallery and supportive functions. See https://design.blog.documentfoundation.org/2015/04/02/libreoffice-design-session-shapes/

However, release early, release often - will ask in the design meeting if we suggest to go with what we have.
Comment 4 Thomas Lendo 2018-04-24 18:25:17 UTC
Due to the many complains about the current state, I would go with the idea to expand the shape section to the whole sidebar height and remove the experimental status. But I hope the full functionality of the shape sidebar deck will someday be realized.
Comment 5 Heiko Tietze 2018-05-01 08:51:46 UTC
Created attachment 141805 [details]
Master

No scrollbar on my system but there is not much more to show anyway. So the issue is a bad calculation of height.
Comment 6 Heiko Tietze 2018-05-01 08:53:48 UTC
Let's add the original developer.
Comment 7 V Stuart Foote 2018-05-01 13:40:35 UTC
The "missing" content panel, as in yet to be developed, is intended to hold linked objects beyond content of Draw's toolbars that have been worked into the current fixed height content panel.

Think of it as adding a GUI to organize generic SVG or Visio stencils to use for diagramming and robust chart work.

In the interim the "Default" content panel, which uses current icon theme for tools, should probably be tweaked to expand to fill the Shapes deck. And probably can be removed from experimental status, with an understanding that the additional "More" content panel remains to be developed and added to complete needed function.


=-ref-=

From cmnt#28 of bug 87643:
> ... can you clarify what is the purpose of the 'more' content panel?

It is to provide non-builtin shapes that are common in diagram apps. These shapes will be stored in files, similar to how we have it for the gallery.

or cmnt#33

Just for reference, the published version of this design session is here,

https://user-prompt.com/libreoffice-design-session-shapes/

and which shapes/stencils are most important to users can be seen on that page by clicking the 'View Results' link, as well as here.

https://design.blog.documentfoundation.org/2016/04/01/the-many-faced-god-part-2-how-libreoffice-draw-is-expected-to-evolve/
Comment 8 Cor Nouws 2018-05-09 14:18:07 UTC
(In reply to Thomas Lendo from comment #4)
> Due to the many complains about the current state, I would go with the idea
> to expand the shape section to the whole sidebar height and remove the
> experimental status. But I hope the full functionality of the shape sidebar
> deck will someday be realized.

+1
Comment 9 Heiko Tietze 2018-05-14 15:31:51 UTC
(In reply to Heiko Tietze from comment #5)
> No scrollbar on my system but there is not much more to show anyway.

Fooled by the issue as no scrollbar hides away things below if the scorllbar is hidden itself. So we all agree on making the list full size.
Comment 10 Heiko Tietze 2018-05-14 16:52:01 UTC
Patch at https://gerrit.libreoffice.org/#/c/54339/
Comment 11 Commit Notification 2018-05-15 06:46:29 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8ab79071d8beed7459711df8a5df7a731fbf2271

tdf#117186 - Sidebar: Shapes deck should fill the whole sidebar

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Thomas Lendo 2018-05-24 21:28:39 UTC
Thanks, Heiko.

VERIFIED with Version: 6.1.0.0.alpha1+
Build ID: 6fecbff9810ae9afc2de8c4d5e9e8a8a511d1f2d
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 13 Xisco Faulí 2018-05-28 11:11:45 UTC
Niceee!!
Heiko, thanks for fixing this. Do you think we should enable the mouse wheel for scrolling here, same way it's done in the Gallery? Should i report a new bug?
Comment 14 Heiko Tietze 2018-05-28 19:43:46 UTC
(In reply to Xisco Faulí from comment #13)
> Niceee!!
> Heiko, thanks for fixing this. Do you think we should enable the mouse wheel
> for scrolling here, same way it's done in the Gallery? Should i report a new
> bug?

The mouse wheel scrolls in lists, if that doesn't work it's a bug.