Bug Hunting Session
Bug 117210 - Superfluous warning about data loss when opening XLSX file with defined worksheet style
Summary: Superfluous warning about data loss when opening XLSX file with defined works...
Status: CLOSED DUPLICATE of bug 116274
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-24 14:53 UTC by ondrej
Modified: 2018-04-24 15:22 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Open test.xlsx to reproduce the bug: a redundant warning will be shown on file open. (9.31 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-04-24 14:54 UTC, ondrej
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ondrej 2018-04-24 14:53:00 UTC
Description:
If an XLSX file (created with MS Excel) has defined column styles in the whole worksheet, the following warning dialog box is shown at startup:
--
Warning loading document test.xlsx:
The data could not be loaded completely because the maximum number of columns per sheet was exceeded.
--

But there is no data after the ODS limit, only column definitions. So this warning is redundant.

Steps to Reproduce:
1. Create a new XLSX file with Excel 2007 or newer.
2. Click the upper-left cell header between A and 1 to select all cells.
3. Change font style and background color. The properties will be applied to all cells.
4. Save the XLSX file.
5. The sheet1.xml in the XLSX file will look like this:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<worksheet xmlns="http://schemas.openxmlformats.org/spreadsheetml/2006/main" xmlns:r="http://schemas.openxmlformats.org/officeDocument/2006/relationships">
  <dimension ref="A1"/>
  <sheetViews>
    <sheetView tabSelected="1" workbookViewId="0">
      <selection activeCell="A2" sqref="A2"/>
    </sheetView>
  </sheetViews>
  <sheetFormatPr baseColWidth="10" defaultColWidth="6.85546875" defaultRowHeight="15"/>
  <cols>
    <col min="1" max="16384" width="6.85546875" style="1"/>
  </cols>
  <sheetData>
    <row r="1" spans="1:1">
      <c r="A1" s="1" t="s">
        <v>0</v>
      </c>
    </row>
  </sheetData>
  <pageMargins left="0.7" right="0.7" top="0.78740157499999996" bottom="0.78740157499999996" header="0.3" footer="0.3"/>
  <pageSetup paperSize="9" orientation="portrait" horizontalDpi="0" verticalDpi="0" r:id="rId1"/>
</worksheet>

-> note the col/@max value of 16384: <col [...] max="16384" [...] />

6.) Open the XLSX file with LibreOffice 6.0.3.2. It will report a warning although there is no data after the ODS limit.

LibreOffice 5.1.6.2 doesn't report any warning when opening the file.

Actual Results:  
The following warning is shown:

Warning loading document test.xlsx:
The data could not be loaded completely because the maximum number of columns per sheet was exceeded.

Expected Results:
No warning should be shown because there is no data after the limit and thus nothing is lost.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.3.2 (x64)
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: cs-CZ (cs_CZ); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36 OPR/52.0.2871.64
Comment 1 ondrej 2018-04-24 14:54:47 UTC
Created attachment 141596 [details]
Open test.xlsx to reproduce the bug: a redundant warning will be shown on file open.
Comment 2 Eike Rathke 2018-04-24 15:21:46 UTC
Fixed for bug 116274.

*** This bug has been marked as a duplicate of bug 116274 ***