Bug Hunting Session
Bug 117304 - Styles and Macros nodes don't expand on double click in the Customize dialog
Summary: Styles and Macros nodes don't expand on double click in the Customize dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2018-04-27 21:41 UTC by Muhammet Kara
Modified: 2018-05-03 16:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Muhammet Kara 2018-04-27 21:41:55 UTC
Open the Customize dialog by following the path Tools > Customize...

Select "Styles" or "Macros" from the category list on the left. (in Menus or Toolbars tabs)

The tree nodes on the laft list box should be expanded/collapsed by double-clicking on the node text, or by single clicking on the node icon.

On current master, double clicking on the node text doesn't work.
Comment 1 Muhammet Kara 2018-04-27 21:45:41 UTC
fad4ed3300ec5b5036fa6436f283606908fa37a3 is the first bad commit
commit fad4ed3300ec5b5036fa6436f283606908fa37a3
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Fri Mar 2 07:07:55 2018 +0100

    2018-03-02: source-hash-86978ae2471d8a4678b78679540db52a71b2571a

:100644 100644 eb3618f08e9becb40836c3d77e81d0ea971a406b 9f15b1ea90c9a7565b961469c8442592ce1a5691 M	build-info.txt
:040000 040000 35faa2e226e663c3155de745b576653219e8d007 03a9ba45f283fa96967e942795974c7c754ddd25 M	opt




------------



$ git bisect log
# bad: [919b99e3459fb812bf50f8a6e015a32bd25fe397] 2018-04-27: source-hash-e9ac3a9c1ee7689c4d591a68250666c95632bd2a
# good: [b2867ebe51334d6f6aa7e45f8ebd402ca388142e] 2017-11-26: source-hash-10593acac0bc42878fea34fe7da3f389f256c317
git bisect start 'origin/master' 'b2867ebe51334d6f6aa7e45f8ebd402ca388142e'
# good: [6517308a5f096e57dc3a5caf86a344dfea6dabac] 2018-02-10: source-hash-48cf115778b29ab916dd884d0bfcfeffd03e7603
git bisect good 6517308a5f096e57dc3a5caf86a344dfea6dabac
# bad: [5ff4aa5f7170ee5a8c798aa4848e4cd9d34e3e1d] 2018-03-20: source-hash-e2b941fef3d0fb955c2528ea2d3f91f62685912e
git bisect bad 5ff4aa5f7170ee5a8c798aa4848e4cd9d34e3e1d
# good: [8b948bbb73a8e5134821a0ac48da0ab695a78d3b] 2018-03-01: source-hash-d64ce643275e0b2b0dea9e532fc261391dc8793c
git bisect good 8b948bbb73a8e5134821a0ac48da0ab695a78d3b
# bad: [af941d8f923b7e29bbb6e153bca2ba02bfd94971] 2018-03-10: source-hash-0d1479cbd442c3ec3bdd20333c341ea24dcca21e
git bisect bad af941d8f923b7e29bbb6e153bca2ba02bfd94971
# bad: [a2651bb2c396e1fee61abb9e12829a4ad2200ba6] 2018-03-05: source-hash-ab63510e104c4b8e42982390357af1281c4b11a7
git bisect bad a2651bb2c396e1fee61abb9e12829a4ad2200ba6
# bad: [4cb6c22c53d2ac2e0a583cf1d8f708a030b5d338] 2018-03-03: source-hash-44b4ad7d210097fdaed7dd94c5746b03f43592d3
git bisect bad 4cb6c22c53d2ac2e0a583cf1d8f708a030b5d338
# bad: [fad4ed3300ec5b5036fa6436f283606908fa37a3] 2018-03-02: source-hash-86978ae2471d8a4678b78679540db52a71b2571a
git bisect bad fad4ed3300ec5b5036fa6436f283606908fa37a3
# first bad commit: [fad4ed3300ec5b5036fa6436f283606908fa37a3] 2018-03-02: source-hash-86978ae2471d8a4678b78679540db52a71b2571a
Comment 2 Muhammet Kara 2018-04-30 21:22:57 UTC
Bisected.

----

7651e57573952758032ceb88f16e2dbbb6cc4e18 is the first bad commit
commit 7651e57573952758032ceb88f16e2dbbb6cc4e18
Author: Jan Holesovsky <kendy@collabora.com>
Date:   Thu Mar 1 12:13:53 2018 +0100

    tdf#115950: Indicate that the dialog was already destroyed.
    
    The DoubleClickHdl()'s return value does not mean "was handled", but actually
    "is there anything more to be done"; so if we actually destroy the dialog in
    the aDoubleClickHdl.Call(this), we have to return 'false'.
    
    Change-Id: I7c510e8341eb5f74703b4266f86cb1e840a2b1fd
    Reviewed-on: https://gerrit.libreoffice.org/50261
    Tested-by: Jenkins <ci@libreoffice.org>
    Reviewed-by: Jan Holesovsky <kendy@collabora.com>

:040000 040000 4ebf97a7ef98d586c7ed7b6d66be2051f38e23ce e613ba430d314fed8848cc07b457f38de89aa211 M	svtools
Comment 3 Muhammet Kara 2018-05-03 11:53:40 UTC
Can't reproduce on master as of f5a56c367fba1c42b4f9719b10ff3e86ad5e2ab1

I don't know which commit solved this.
Comment 4 Aron Budea 2018-05-03 16:00:46 UTC
Fixed by the following commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b649ce123dea372359ec571135a68eb3de844e5b
author		Jim Raykowski <raykowj@gmail.com>	2018-04-17 18:07:39 -0800
committer	Heiko Tietze <tietze.heiko@gmail.com>	2018-04-29 08:46:46 +0200

tdf#117063 Modify tree list double click behavior in the navigator