Bug 117344 - Enhancement request in calc: Option of changing predicted text from alphabetical to most used
Summary: Enhancement request in calc: Option of changing predicted text from alphabeti...
Status: RESOLVED DUPLICATE of bug 43742
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-30 08:27 UTC by Michael
Modified: 2018-06-07 14:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2018-04-30 08:27:07 UTC
Description:
When creating a spreadsheet, if I have a column where there are frequently repeated values, it would be handy to have the suggestion based on the most used rather than alphabetical (as you don't get multiple options anyway).

For example, I do finances on a spreadsheet, and one of the columns is the location the receipt is from. Say I go to Burger King all the time, its handy when I put "B" or "Bu" to just tab to the next field and "Burger King" would come up. Now say I go to a place while on holidays (as a once off) named Burger Bites. Once this is entered, it will always be the default until I type "Burger K" as it is alphabetically first (seems to be how it works from experimenting).

I think the way it calculates suggested text is most used (as you are most likely to want that) or at least a setting you can change to make it this way.

Steps to Reproduce:
1. Type "Burger King" into A1, A2 and A3
2. Type "Bu" into A4, "Burger King" should be suggested, so press enter
3. Type "Burger Bites" into A5
4. Type "Bu" into A6, now in this field and any other fields this will be suggested as "Burger Bites", would be more useful to be "Burger King"

Actual Results:  
"Burger Bites" will be suggested for this column.

Expected Results:
Would like it to say "Burger King" as suggested (while there are more instances of "burger King" in that column).


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
Comment 1 Buovjaga 2018-06-07 14:30:17 UTC

*** This bug has been marked as a duplicate of bug 43742 ***