Download it now!
Bug 117363 - soffice binary cannot create a new LibreOffice file
Summary: soffice binary cannot create a new LibreOffice file
Status: RESOLVED DUPLICATE of bug 40227
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.3.1 rc
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL: https://ask.libreoffice.org/en/questi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-01 04:04 UTC by Ivan Homoliak
Modified: 2018-05-01 13:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Homoliak 2018-05-01 04:04:16 UTC
Description:
In command line: executing "soffice --calc new.ods" does not create a new file in the current directory, but instead of it just error message "File new.ods does not exist" is displayed.

Thus, there is no option how to create a new LibreOffice file from the command line - tested on Windows and Linux, for further details, see https://ask.libreoffice.org/en/question/153444/how-to-create-empty-libreoffice-file-in-a-current-directory-on-the-command-line/?comment=153612#post-id-153612

Steps to Reproduce:
1. Ensure that soffice binary can be executed from your command line
2. Run >soffice.exe --calc newfile.ods
3. Observe the error dialogue

Actual Results:  
Error dialogue complaining about nonexistence of file.

Expected Results:
A new LibreOffice file (calc) should be created in the current directory


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.3.2 (x64)
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: en-US (en_US); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.117 Safari/537.36
Comment 1 Maxim Monastirsky 2018-05-01 13:04:33 UTC

*** This bug has been marked as a duplicate of bug 40227 ***