Bug 117391 - printing via remote desktop seems not to work
Summary: printing via remote desktop seems not to work
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Remote
  Show dependency treegraph
 
Reported: 2018-05-02 13:43 UTC by Meetup
Modified: 2018-11-27 16:08 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Meetup 2018-05-02 13:43:13 UTC
Description:
i work on PC A and go via remote desktop to PC B. Then I want to print on a printer that is connected to PC A.
In LO it worked always well. Now it does not work at all in V6.0.32 X64.
Printing from others applications on PC B does work.
When I press Ctrl+P, the printing menu comes visible, and a can choose anything, but the printing will NOT happen. 
I fI open the printing menu, then the order to print is not waiting etc etc

Steps to Reproduce:
1. make a remote desktop connection
2.print a testpage from the windows printer menu, to a local printer
3.check if it is printed local (yes)
4) open LO word, make a doc, print the doc, choose the same printer
5) check if it is printed local (no)

Actual Results:  
no print at all

Expected Results:
a print


Reproducible: Always


User Profile Reset: No



Additional Info:
https://gerrit.libreoffice.org/gitweb?p=core.git&a=log&h=8f48d515416608e3a835360314dac7e47fd0b821


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36
Comment 1 Meetup 2018-05-02 14:12:01 UTC
1) restart the external PC
2) start LO , xls. print. works.
  open .doc, print, no printing.
   close doc.
   open .xls print, ALSO no printing.
   close LO
   open LO.
   will not open.
   go to windows taks, there are hidden tasks from LO.
   I close them.
3) I can start 2) again, and the same happens.
Comment 2 Meetup 2018-05-02 14:18:29 UTC
exporting the doc file to the main machine, and open it with LO 5 and printing local does work
Comment 3 Timur 2018-06-07 11:50:06 UTC
No repro with Win 7 RDP to Win 7 32-bit where LO 5.4.7 and LO 6.0.4 print fine. 
No repro with Win 7 RDP to Win 10 64-bit where LO 64-bit 6.0, 6.1 and 6.2+ print fine. 

According to my test, this is not a general LO issue. 
Could be related to Windows versions. 
Please try with some other set of computers and try to pinpoint your problem. 
Please be specific which LO version on PC B works and which not. Try both 32-bit an 64-bit.
You can use http://tdf.io/siguiexe to easily get and run "parallel" LO in Windows (extract without installation) to test LO up to master 6.2+.
Comment 4 Timur 2018-11-27 16:08:30 UTC
Since no response, I'll close.