Bug Hunting Session
Bug 117407 - Assertion failed on opening document
Summary: Assertion failed on opening document
Status: RESOLVED DUPLICATE of bug 117323
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-03 12:06 UTC by Regina Henschel
Modified: 2018-05-03 12:14 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Call stack, better readable (3.93 KB, text/plain)
2018-05-03 12:08 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-05-03 12:06:00 UTC
I use debug build of Version: 6.1.0.0.alpha1+ (x64)
Build ID: f5a56c367fba1c42b4f9719b10ff3e86ad5e2ab1
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL

If I use File > Open, I get the assertion fail:
Assertion failed!

Program: D:\Build_ODF_layers\core\instdir\program\sfxlo.dll
File: D:\Build_ODF_layers\core\include\rtl/ustring.hxx
Line: 669

Expression: index >= 0 && static_cast<sal_uInt32>(index) < static_cast<sal_uInt32>(getLength())

From debugging in Visual Studio 2017 I get the additional information:
pData	0x00007ffe074b14e0 {sal3.dll!_rtl_uString aImplEmpty_rtl_uString} empty	_rtl_uString *

and the call stack:
 	ucrtbase.dll!common_assert_to_message_box<wchar_t>()	Unbekannt
>	sfxlo.dll!rtl::OUString::operator[](long index) Zeile 669	C++
 	sfxlo.dll!sfx2::AppendWildcardToDescriptor::AppendWildcardToDescriptor(const rtl::OUString & _rWildCard) Zeile 467	C++
 	sfxlo.dll!sfx2::lcl_GroupAndClassify(sfx2::TSortedFilterList & _rFilterMatcher, std::list<std::list<com::sun::star::beans::StringPair,std::allocator<com::sun::star::beans::StringPair> >,std::allocator<std::list<com::sun::star::beans::StringPair,std::allocator<com::sun::star::beans::StringPair> > > > & _rAllFilters) Zeile 610	C++
 	sfxlo.dll!sfx2::appendFiltersForOpen(sfx2::TSortedFilterList & _rFilterMatcher, const com::sun::star::uno::Reference<com::sun::star::ui::dialogs::XFilterManager> & _rxFilterManager, rtl::OUString & _rFirstNonEmpty, sfx2::FileDialogHelper_Impl & _rFileDlgImpl) Zeile 1120	C++
 	sfxlo.dll!sfx2::FileDialogHelper_Impl::addFilters(const rtl::OUString & rFactory, SfxFilterFlags nMust, SfxFilterFlags nDont) Zeile 1817	C++
 	sfxlo.dll!sfx2::FileDialogHelper::FileDialogHelper(short nDialogType, FileDialogFlags nFlags, const rtl::OUString & rFact, short nDialog, SfxFilterFlags nMust, SfxFilterFlags nDont, const rtl::OUString & rStandardDir, const com::sun::star::uno::Sequence<rtl::OUString> & rBlackList, weld::Window * pPreferredParent) Zeile 2307	C++
 	sfxlo.dll!sfx2::FileOpenDialog_Impl(weld::Window * pParent, short nDialogType, FileDialogFlags nFlags, std::vector<rtl::OUString,std::allocator<rtl::OUString> > & rpURLList, rtl::OUString & rFilter, SfxItemSet * & rpSet, const rtl::OUString * pPath, short nDialog, const rtl::OUString & rStandardDir, const com::sun::star::uno::Sequence<rtl::OUString> & rBlackList) Zeile 2654	C++
 	sfxlo.dll!SfxApplication::OpenDocExec_Impl(SfxRequest & rReq) Zeile 656	C++
 	sfxlo.dll!SfxStubSfxApplicationOpenDocExec_Impl(SfxShell * pShell, SfxRequest & rReq) Zeile 1231	C++
 	sfxlo.dll!SfxShell::CallExec(void(*)(SfxShell *, SfxRequest &) pFunc, SfxRequest & rReq) Zeile 211	C++
 	sfxlo.dll!SfxDispatcher::Call_Impl(SfxShell & rShell, const SfxSlot & rSlot, SfxRequest & rReq, bool bRecord) Zeile 358	C++
 	sfxlo.dll!SfxDispatcher::PostMsgHandler(SfxRequest * pReq) Zeile 1129	C++
 	sfxlo.dll!SfxDispatcher::LinkStubPostMsgHandler(void * instance, SfxRequest * data) Zeile 1106	C++
 	sfxlo.dll!Link<SfxRequest * __ptr64,void>::Call(SfxRequest * data) Zeile 84	C++
 	sfxlo.dll!SfxHintPoster::DoEvent_Impl(void * pPostedHint) Zeile 45	C++
 	sfxlo.dll!SfxHintPoster::LinkStubDoEvent_Impl(void * instance, void * data) Zeile 42	C++
 	vcllo.dll!Link<void * __ptr64,void>::Call(void * data) Zeile 84	C++
 	vcllo.dll!ImplHandleUserEvent(ImplSVEvent * pSVEvent) Zeile 1931	C++
 	vcllo.dll!ImplWindowFrameProc(vcl::Window * _pWindow, SalEvent nEvent, const void * pEvent) Zeile 2480	C++
 	vcllo.dll!SalFrame::CallCallback(SalEvent nEvent, const void * pEvent) Zeile 279	C++
 	vcllo.dll!ImplHandleUserEvent(HWND__ * hWnd, __int64 lParam) Zeile 4076	C++
 	vcllo.dll!SalFrameWndProc(HWND__ * hWnd, unsigned int nMsg, unsigned __int64 wParam, __int64 lParam, bool & rDef) Zeile 5727	C++
 	vcllo.dll!SalFrameWndProcW(HWND__ * hWnd, unsigned int nMsg, unsigned __int64 wParam, __int64 lParam) Zeile 5834	C++
 	[Externer Code]	
 	vcllo.dll!ImplSalDispatchMessage(const tagMSG * pMsg) Zeile 458	C++
 	vcllo.dll!ImplSalYield(bool bWait, bool bHandleAllCurrentEvents) Zeile 484	C++
 	vcllo.dll!WinSalInstance::DoYield(bool bWait, bool bHandleAllCurrentEvents) Zeile 555	C++
 	vcllo.dll!ImplYield(bool i_bWait, bool i_bAllEvents) Zeile 470	C++
 	vcllo.dll!Application::Yield() Zeile 536	C++
 	vcllo.dll!Application::Execute() Zeile 450	C++
 	sofficeapp.dll!desktop::Desktop::Main() Zeile 1632	C++
 	vcllo.dll!ImplSVMain() Zeile 198	C++
 	vcllo.dll!SVMain() Zeile 237	C++
 	sofficeapp.dll!soffice_main() Zeile 170	C++
 	soffice.bin!sal_main() Zeile 48	C
 	soffice.bin!main(int argc, char * * argv) Zeile 47	C
 	soffice.bin!WinMain(void * _hinst, void * _dummy, char * _cmdline, int _nshow) Zeile 47	C
 	[Externer Code]
Comment 1 Regina Henschel 2018-05-03 12:08:57 UTC
Created attachment 141863 [details]
Call stack, better readable
Comment 2 Aron Budea 2018-05-03 12:14:18 UTC

*** This bug has been marked as a duplicate of bug 117323 ***