Bug Hunting Session
Bug 117413 - double display slightly offset when editing a cell
Summary: double display slightly offset when editing a cell
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.4.1 rc
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.1.0 target:6.0.5
Keywords:
: 117605 (view as bug list)
Depends on:
Blocks: Calc-Cells Cell-Edit-Mode
  Show dependency treegraph
 
Reported: 2018-05-03 14:47 UTC by Jean-Baptiste Faure
Modified: 2018-08-28 07:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
the second cell is double-clicked for editing (10.83 KB, image/png)
2018-05-03 14:47 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2018-05-03 14:47:23 UTC
Created attachment 141870 [details]
the second cell is double-clicked for editing

As requested in comment #93 of bug 100925, I file this new bug report:

Steps to reproduce:
1/ open an existing spreadsheet with LO 6.0.5.0.0+ (current branch 6.0)
2/ double-click inside a cell to edit its content
what happens: if the cell is larger than its content, the content is displayed two time with a small offset. When moving the cursor left the content displayed may become unreadable.

Conditions to reproduce:
1/ GTK3 backend
2/ several cells before the one to be edited

I did a bisection on branch 6.0 and found that the problem started with the following commit: https://gerrit.libreoffice.org/gitweb?p=core.git;a=commit;h=28f2941680f850e88228e45699ac612ce036cf16

I have the same problem with the master.

Best regards. JBF
Comment 1 Buovjaga 2018-05-03 15:22:09 UTC
I repro.

Arch Linux 64-bit
Version: 6.1.0.0.alpha1+
Build ID: 03a4b6eb58b29c0ab4bb85f756923c46618d02ff
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on May 2nd 2018
Comment 2 Caolán McNamara 2018-05-04 10:53:07 UTC
maybe this is some sort of self drawing problem where the source and target are the same surface and source and destination overlap
Comment 3 Caolán McNamara 2018-05-04 16:19:08 UTC
if you can reproduce it (which I can't, as is typical) can you see if https://gerrit.libreoffice.org/#/c/53860/ makes a difference, and what "type is" value gets output ?
Comment 4 Buovjaga 2018-05-04 18:07:51 UTC
(In reply to Caolán McNamara from comment #3)
> if you can reproduce it (which I can't, as is typical) can you see if
> https://gerrit.libreoffice.org/#/c/53860/ makes a difference, and what "type
> is" value gets output ?

It does make a positive difference - I am not seeing the mess anymore! I also tested the other VCL backends to be sure they stayed healthy.
Comment 5 Buovjaga 2018-05-04 18:08:15 UTC
(In reply to Buovjaga from comment #4)
> (In reply to Caolán McNamara from comment #3)
> > if you can reproduce it (which I can't, as is typical) can you see if
> > https://gerrit.libreoffice.org/#/c/53860/ makes a difference, and what "type
> > is" value gets output ?
> 
> It does make a positive difference - I am not seeing the mess anymore! I
> also tested the other VCL backends to be sure they stayed healthy.

Ah, sorry, the output is:
type is 3
Comment 6 Caolán McNamara 2018-05-04 20:23:58 UTC
ok, thats encouraging. So here's my proposed final patch https://gerrit.libreoffice.org/#/c/53860/ I assume that still works ?
Comment 7 Jean-Baptiste Faure 2018-05-04 21:18:50 UTC
(In reply to Caolán McNamara from comment #3)
> if you can reproduce it (which I can't, as is typical) can you see if
> https://gerrit.libreoffice.org/#/c/53860/ makes a difference, and what "type
> is" value gets output ?

That makes a difference: no problem anymore. It still works as expected if gtk2 backend is used instead of gtk3 
type is 3 if gtk3, no output if gtk2.

Best regards. JBF
Comment 8 Buovjaga 2018-05-05 07:13:09 UTC
(In reply to Caolán McNamara from comment #6)
> ok, thats encouraging. So here's my proposed final patch
> https://gerrit.libreoffice.org/#/c/53860/ I assume that still works ?

Yep, it still works.

Sadly Jenkins complains about a failed unit test on Win https://ci.libreoffice.org/job/gerrit_windows/5323/console
Comment 9 Jean-Baptiste Faure 2018-05-05 08:28:41 UTC
(In reply to Buovjaga from comment #8)
> (In reply to Caolán McNamara from comment #6)
> > ok, thats encouraging. So here's my proposed final patch
> > https://gerrit.libreoffice.org/#/c/53860/ I assume that still works ?
> 
> Yep, it still works.

Idem for me.

> 
> Sadly Jenkins complains about a failed unit test on Win
> https://ci.libreoffice.org/job/gerrit_windows/5323/console

No problem with unit tests for me under Linux.

Best regards. JBF
Comment 10 Caolán McNamara 2018-05-05 20:16:42 UTC
excellent, windows failure is bogus wrt this patch as its not on the windows code path. will try build again, picked to proposed 6-0 in gerrit in the meantime
Comment 11 Commit Notification 2018-05-06 13:39:23 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=95620da00dc53a061c3b093510e46a7c0b3163c6

Resolves: tdf#117413 char doubling appearing under X with gtk3

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Jean-Baptiste Faure 2018-05-06 15:52:13 UTC
Thank you very much, this patch fixes the bug for me on master. If needed I can test the cherrypicked patch for 6.0.

Best regards. JBF
Comment 13 Jean-Baptiste Faure 2018-05-14 06:41:04 UTC
*** Bug 117605 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2018-05-14 13:44:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=17e7bd5e17e3393c44c76b7c69d47ad112e5efa6&h=libreoffice-6-0

Resolves: tdf#117413 char doubling appearing under X with gtk3

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 jtallerx 2018-08-28 07:16:17 UTC
I was affected by this bug in Ubuntu 16.04. In LO Calc v5.x, editing existing data was superimposed on the old data while that field is being edited. At the end of editing (ENTER) the new data appeared correctly. The problem was while editing you could not see what you doing.
I installed LO v6.x and the bug is gone.
--thanks