Bug 117459 - CELL() function does not recalculate on non-cell-content-changing events
Summary: CELL() function does not recalculate on non-cell-content-changing events
Status: CLOSED DUPLICATE of bug 85986
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Function
  Show dependency treegraph
 
Reported: 2018-05-06 15:03 UTC by internationils
Modified: 2020-04-14 19:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description internationils 2018-05-06 15:03:43 UTC
I have a cell that contains the name of the worksheet. I use this cell as a reference for a vlookup (irrelevant for this bug report, just for info...)
When the name of the WS is changed, the name in the cell does not change until I do a F9 recalculate. 

I'm using the formula:
=MID(CELL("filename"),FIND("'#$",CELL("filename"))+3,99)

Expected result: The cell contents should change immediately to reflect the new WS name
Comment 1 m.a.riosv 2018-05-06 16:01:49 UTC
You can force it adding a volatile function like NOW() to the formula
=MID(CELL("filename");FIND("'#$";CELL("filename"))+3;99)&T(NOW())
which forces the recalculation of the formula with every change on the spread sheet. 

If I'm not wrong CELL function is calculate when the referenced cell(s) change their value, which seems it's not the case after change the sheet name.

Please Eike can you take a look.
Comment 2 Eike Rathke 2018-05-07 10:22:13 UTC
The CELL() function lacks dependencies on events that are not cell content changes. For "filename" that is renaming a sheet and saving to a different file name. For "format" and related that is changing the applied number format.
Comment 3 internationils 2018-08-31 06:48:03 UTC
Still present in
Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 QA Administrators 2019-09-02 09:24:50 UTC Comment hidden (obsolete)
Comment 5 internationils 2019-10-01 12:42:36 UTC
Still present

Version: 6.2.7.1
Build ID: 1:6.2.7-0ubuntu0.19.04.1
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Eike Rathke 2020-04-14 19:20:02 UTC

*** This bug has been marked as a duplicate of bug 85986 ***