Bug 117460 - Impress crashes when converting image to 3D rotation object, sometimes after moving the image around thereafter
Summary: Impress crashes when converting image to 3D rotation object, sometimes after ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-Images Shapes
  Show dependency treegraph
 
Reported: 2018-05-06 15:18 UTC by Thomas Hackert
Modified: 2018-10-08 18:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["Fraction::GetDenominator() const"]


Attachments
"soffice --backtrace" output (2.99 KB, application/x-bzip)
2018-05-13 13:53 UTC, Thomas Hackert
Details
Callgrind logs (hopefully the right ones) ... (83.40 KB, application/x-bzip)
2018-05-13 13:57 UTC, Thomas Hackert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2018-05-06 15:18:42 UTC
Description:
Hello @ll,
while translating test cases for our testlink instance to German, I discovered the following:

Steps to Reproduce:
1. Start Impress
2. insert an image (I have tested an *..jpg, *.png and *.eps)
3. rightclick on the inserted image and choose "Convert to 3D Rotation Object"

In some tests, LO crashed at that point. Sometimes I needed to move the converted image a short time around (to the left and/or back and/or to the right, or up and down, etc.). But the result is still the same: LO crashes ... :(

Actual Results:  
Impress crashes (e.g. crashreport.libreoffice.org/stats/crash_details/7d927995-6cb7-462c-9b10-da6e2f026c35 is one of the crashreports ... :( )

Expected Results:
Impress should not crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
OS: Debian Testing AMD64
LO: Version: 6.1.0.0.alpha1
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux with de_DE lang- as well as helppack)


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Comment 1 Julien Nabet 2018-05-07 09:53:39 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
Badfully, I can't retrieve a bt since I can't reproduce this when using gdb (either with make debugrun or by attaching gdb to the process).

However, I had these on console:
warn:vcl.gdi:7764:7764:vcl/source/graphic/Manager.cxx:129: Calculated size mismatch. Variable size is '2483788' but calculated size is '1697356'
warn:vcl.gdi:7678:7678:vcl/source/outdev/map.cxx:1778: Invalid source map unit
soffice.bin: /home/julien/lo/libreoffice/include/o3tl/enumarray.hxx:60: const V& o3tl::enumarray<E, V>::operator[](E) const [with E = MapUnit; V = long int]: Assertion `index>=static_cast<E>(0) && index<=E::LAST' failed.
warn:vcl:7678:7678:vcl/source/window/dialog.cxx:864: Dialog::StartExecuteModal() - Parent not visible
Comment 2 Xisco Faulí 2018-05-07 10:21:35 UTC
I can reproduce it in

Version: 6.1.0.0.alpha1+
Build ID: 1e2afc9bd3062cfba6b65b45c17a08f298014239
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

I used this imagge ( http://www.misucell.com/data/out/11/IMG_472485.jpg ) to reproduce it..
Comment 3 Xisco Faulí 2018-05-07 10:23:55 UTC
I can also reproduce it in

Version: 6.0.3.2
Build ID: 1:6.0.3~rc2-0ubuntu0.16.04.1~lo2
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
but not in

Versión: 6.0.3.2
Id. de compilación: 8f48d515416608e3a835360314dac7e47fd0b821
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group
Comment 4 Thomas Hackert 2018-05-13 13:53:59 UTC
Created attachment 142078 [details]
"soffice --backtrace" output

Hello @ll,
thanks for confirming the bug and sorry for the delay ... :( Have not found the time before to create a backtrace ... :(
Sorry again
Thomas.
Comment 5 Thomas Hackert 2018-05-13 13:57:43 UTC
Created attachment 142079 [details]
Callgrind logs (hopefully the right ones) ...

Hello @ll,
as I was not able to produce a strace output the crash, I installed valgrind and tried a couple of times to reproduce it with that ... ;) Though it was slowing down my system with "soffice --valgrind" I could not reproduce the crash either but with "algrind --tool=callgrind --simulate-cache=yes --dump-instr=yes LO/instdir/daily/master/opt/libreofficedev6.1/program/soffice --splash-pipe=0" I could somehow reproduce it ...
Sorry for the inconvenience
Thomas.
Comment 6 Julien Nabet 2018-05-16 18:49:36 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.
Xisco: do you reproduce this with a more recent daily build?