Download it now!
Bug 117474 - Missing page-shadow-mask.png
Summary: Missing page-shadow-mask.png
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: andreas_k
URL:
Whiteboard: target:6.1.0
Keywords: haveBacktrace
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2018-05-07 10:50 UTC by Julien Nabet
Modified: 2018-05-09 14:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (5.34 KB, text/plain)
2018-05-07 10:51 UTC, Julien Nabet
Details
page-shadow-mask.png from Galaxy (692 bytes, image/png)
2018-05-08 07:26 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2018-05-07 10:50:24 UTC
Description:
On pc Debian x86-64 with master sources updated yesterday, I noticed this message on console:
warn:legacy.osl:8113:8113:drawinglayer/source/primitive2d/discreteshadowprimitive2d.cxx:47: DiscreteShadowPrimitive2D: wrong bitmap format (!)
After some gdb session, I found that it was due to the missing file page-shadow-mask.png

Steps to Reproduce:
1. Open Writer

Actual Results:  
warn:legacy.osl:8113:8113:drawinglayer/source/primitive2d/discreteshadowprimitive2d.cxx:47: DiscreteShadowPrimitive2D: wrong bitmap format (!)

Expected Results:
This message shouldn't appear


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Julien Nabet 2018-05-07 10:51:02 UTC
Created attachment 141951 [details]
bt with debug symbols
Comment 2 Heiko Tietze 2018-05-08 07:26:11 UTC
Created attachment 141964 [details]
page-shadow-mask.png from Galaxy

Another one for the master of Colibre. This icon lifes in sw/res/page-shadow-mask.png but I don't spot it in Writer.
Comment 3 andreas_k 2018-05-08 17:11:06 UTC
Thanks for the bug report fixed with 
https://gerrit.libreoffice.org/#/c/53997/
Comment 4 Commit Notification 2018-05-08 17:11:16 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=243e17a5c4a406eafd5fffe751e3cf28e555cc17

tdf#117474 Colibre icons: add page-shadow-mask from galaxy

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2018-05-09 14:45:01 UTC
Thank you for the patch! :-)