Bug Hunting Session
Bug 117481 - no images in buttons in Database pane in main database window
Summary: no images in buttons in Database pane in main database window
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.2.0 target:6.1.0.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2018-05-07 14:51 UTC by Terrence Enger
Modified: 2018-05-28 11:53 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
tail of bibisect output, daily linux dbgutil repo (2.30 KB, text/plain)
2018-05-07 14:51 UTC, Terrence Enger
Details
Screen shot Base w/Elementary icon set (50.82 KB, image/png)
2018-05-16 21:58 UTC, Drew Jensen
Details
Screen shot Base w/Tango icon set (55.05 KB, image/png)
2018-05-16 22:00 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2018-05-07 14:51:38 UTC
Created attachment 141960 [details]
tail of bibisect output, daily linux dbgutil repo

STR

(1) Create a new database file (I created a new embedded Firebird) or
    open an existing one (I opened TestDB.odb in attachment to
    tdf#118271, embedded HSQLDB).

(2) In main database window, in pane Database, observe the four
    buttons Tables, Queries, Forms, Reports.

    Expected : an image on each button
    Observed : no image

Working on debian-buster with the daily Linux dbgutil bibisect
repository, I see that the bug happened somewhere in the 16 or so
commits to master:

          commit    date        s-h
          --------  ----------  --------
    good  2f656af5  2018-05-05  6bbaed85  good
    bad   72ac05c5  2018-05-06  e89dc1b6  bad
Comment 1 Terrence Enger 2018-05-07 14:53:43 UTC
I am setting severity minor and keywords regression, bibisected and am
adding Rene Engelhard to cc.
Comment 2 Xisco Faulí 2018-05-07 15:04:27 UTC
happening after

author	heiko tietze <tietze.heiko@gmail.com>	2018-04-18 12:22:07 +0200
committer	Heiko Tietze <tietze.heiko@gmail.com>	2018-05-05 10:19:26 +0200
commit	60413c9800c27f53c1108015b50754b065bc98c6 (patch)
tree	a0f5a128c529c786c8200ce546a3730997549988
parent	f6fb5a17da883e89cae6f7a960266fc87ccc9f6b (diff)
Replace Galaxy icon theme by Colibre

Bisected with: bibisect-linux64-6.1

Adding Cc: to heiko tietze
Comment 3 Terrence Enger 2018-05-07 15:15:18 UTC
Seeing c#2, I am removing Rene Engelhard from cc.
Comment 4 Julien Nabet 2018-05-16 19:42:57 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Andreas: I noticed these logs on console
warn:vcl:12215:12215:vcl/source/gdi/bitmapex.cxx:107: BitmapEx::BitmapEx(): could not load image dbaccess/res/tables_32.png via icon theme elementary
warn:vcl:12215:12215:vcl/source/gdi/bitmapex.cxx:107: BitmapEx::BitmapEx(): could not load image dbaccess/res/queries_32.png via icon theme elementary
warn:vcl:12215:12215:vcl/source/gdi/bitmapex.cxx:107: BitmapEx::BitmapEx(): could not load image dbaccess/res/forms_32.png via icon theme elementary
warn:vcl:12215:12215:vcl/source/gdi/bitmapex.cxx:107: BitmapEx::BitmapEx(): could not load image dbaccess/res/reports_32.png via icon theme elementary
Comment 5 andreas_k 2018-05-16 21:41:46 UTC
Screenshot would be nice
Comment 6 Julien Nabet 2018-05-16 21:53:58 UTC
Badfully, I don't succeed in using Gimp to create a screenshot whereas I had done it many times in the past.

Andreas: the missing icons are just the four ones on left panel when opening an existing odb file: tables, queries, forms, reports.
Comment 7 Drew Jensen 2018-05-16 21:58:39 UTC
Created attachment 142138 [details]
Screen shot Base w/Elementary icon set

The main button images (left hand of page) are missing.
The Table (and other icons) are wrong.
Comment 8 Drew Jensen 2018-05-16 22:00:01 UTC
Created attachment 142139 [details]
Screen shot Base w/Tango icon set

Same test system Libo 6.1 Alpha (build earlier today) but changed to Tango icon set.

Four missing icons are there, wrong table icons are now correct.
Comment 9 Commit Notification 2018-05-19 10:27:15 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3374c1a52ea579d9ce0909ad1792d8e854c90d6a

tdf#117481 copy base 32 px sidebar icons from res folder

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Drew Jensen 2018-05-21 15:36:41 UTC
Checked this with:
Version: 6.1.0.0.alpha1+
Build ID: 6e7e4d9f02f286ccb817cb2c1f54a951dcebffad
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-05-21_01:55:12
Locale: en-US (en_US.UTF-8); Calc: group
(Ubuntu 18.04)

Which according to gerritt includes this patch.

However, no love, and still no icons on the main base window buttons AND still wrong icons for the different assets (Tables, Queries, Forms and Reports).
Comment 11 Julien Nabet 2018-05-21 15:37:15 UTC
On pc Debian x86-64 with master sources updated today + make clean, I still reproduce this with same messages:
warn:vcl:14637:14637:vcl/source/gdi/bitmapex.cxx:107: BitmapEx::BitmapEx(): could not load image dbaccess/res/tables_32.png via icon theme elementary
warn:vcl:14637:14637:vcl/source/gdi/bitmapex.cxx:107: BitmapEx::BitmapEx(): could not load image dbaccess/res/queries_32.png via icon theme elementary
warn:vcl:14637:14637:vcl/source/gdi/bitmapex.cxx:107: BitmapEx::BitmapEx(): could not load image dbaccess/res/forms_32.png via icon theme elementary
warn:vcl:14637:14637:vcl/source/gdi/bitmapex.cxx:107: BitmapEx::BitmapEx(): could not load image dbaccess/res/reports_32.png via icon theme elementary

But since the added icons concern colibri and colibri_svg, it was expected.
Andreas: any thoughts about this one?
Comment 12 Commit Notification 2018-05-23 14:35:00 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=30e34899cec5a518328fc8aaa9cf2c02faf214ac

tdf#117481 Add dbaccess icons for base sidebar

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 andreas_k 2018-05-23 14:36:45 UTC
Elementary and breeze will follow. The elementary icon has to be drawn first.
Comment 14 Commit Notification 2018-05-23 21:20:54 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=748215da08dba56125e3a671381d1e872bd1ecc7

tdf#117481 Elementary: Add dbaccess icons for base sidebar

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-05-23 21:27:01 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6fecbff9810ae9afc2de8c4d5e9e8a8a511d1f2d

tdf#117481 Breeze Add dbaccess icons for base sidebar

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Julien Nabet 2018-05-24 16:39:01 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce the pb.
Thank you Andreas!
Comment 17 Commit Notification 2018-05-28 06:29:12 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=18c85f770bca04f71b03c4ca06da1a0488842512

tdf#117481 Karasa Jaga: Add dbaccess icons for base sidebar

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-05-28 08:09:37 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba5b318fd04d056d5301fba43bd3953e7c8c181f&h=libreoffice-6-1

tdf#117481 Karasa Jaga: Add dbaccess icons for base sidebar

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2018-05-28 11:53:07 UTC
(In reply to Julien Nabet from comment #16)
> On pc Debian x86-64 with master sources updated today, I don't reproduce the
> pb.
> Thank you Andreas!

Setting to VERIFIED then