Bug 117487 - Calc treats 'rows' and mouse 'scroll lines' as being the same
Summary: Calc treats 'rows' and mouse 'scroll lines' as being the same
Status: RESOLVED DUPLICATE of bug 40917
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-07 17:23 UTC by id22345
Modified: 2021-10-30 18:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description id22345 2018-05-07 17:23:28 UTC
Description:
In Mouse settings there is option to set mouse scroll lines or how many 'lines' the mouse scroll wheel moves up or down the page per increment.  in bad design Calc treats rows and 'scroll lines' as the same. This can cause annoying navigation problems if you have a lot of text in a cell. It is bad design and should obviously be fixed.

Steps to Reproduce:
1.  Open up Calc and insert a paragraph of text into some cells down a column. use 'text wrap' if needed.
2.  watch what happens when you use your scroll wheel on your mouse.
3.  That is all

Actual Results:  
For most people the scroll wheel will move up or down 3 or 5 'rows'. so if you have a big row because you have a lot of text in a cell this whole body of text be treated as one 'scroll line'. This is very annoying.

Expected Results:
'rows' and 'scroll lines' should be two separate things. They should not be conflated with each other. When I use the scroll wheel the increment should be the number of 'scroll lines' I have designated in 'mouse settings', Not the number of 'rows' in Calc when in Calc environment.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows 10
OS is 64bit: Yes
log address:  https://gerrit.libreoffice.org/gitweb?p=core.git&a=log&h=8f48d515416608e3a835360314dac7e47fd0b821


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Telesto 2018-05-07 18:23:21 UTC
Maybe related to bug 34689 and or bug 40917
Comment 2 V Stuart Foote 2018-05-07 21:19:23 UTC
Hmm, lets check the use case... 

Have a user *abusing* a Calc spreadsheet with multi-line cell content, and then complaining that the scroll is done with single _row_ increments rather than with _line_ increments of wrapped text held in an over height cell.

Sorry, but this behavior is by design and needed for sheet performance.

Alternatives have been evaluated in the past and current _row_ unit scroll granularity is retained for performance issues with rendering cell grid of Calc sheets.

Instead (as a GSOC 2011 project, for 3.5.0 release) we implemented a multi-line capable Formula input bar to fully expose such ill-advised multi-line cell content, including scroll at _line_ increments within the active cell.

Anyhow => DUPLICATE of bug 35759 or bug 34689

*** This bug has been marked as a duplicate of bug 35759 ***
Comment 3 V Stuart Foote 2021-10-30 18:27:50 UTC

*** This bug has been marked as a duplicate of bug 40917 ***