Bug 117489 - The existing direct formatting is not replaced when applying a table style
Summary: The existing direct formatting is not replaced when applying a table style
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2018-05-07 20:47 UTC by Telesto
Modified: 2022-04-21 14:06 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-05-07 20:47:53 UTC Comment hidden (obsolete)
Comment 1 Dieter 2018-05-08 07:29:38 UTC
Not reproducible for me with

Version: 6.1.0.0.alpha1+ (x64)
Build ID: 775d0f26beecffccf3ed27a6a011aff20d91f842
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-26_01:05:25
Locale: en-US (de_DE); Calc: CL

I changed the background color to red. It was applied to all styles(of course with the exception of Box List Blue, Green and Yellow and Simle Grid Rows), including cell A1.
Comment 2 Telesto 2018-05-08 08:43:07 UTC
(In reply to Dieter Praas from comment #1)
You're right, steps aren't working as expected :-). Small change (leave it at cell instead of table)

1. Insert a table (2x2) (without formatting)
2. Select 1 or more cell's 
2. Table -> Properties -> Background
3. Select Color & Select Cell -> Press OK
4. Open the styles pane in the sidebar -> Table styles -> Select a style
5. No change in the first cell (if a single cell is selected)/ Or table if all cells are modified this way
Comment 3 Telesto 2018-05-08 08:45:10 UTC
Same type of problem can be observed with table borders. 

1. Insert a table (2x2) (without formatting)
2. Table -> Properties -> Borders
3. Change the line width/color -> OK
4. Open the styles pane in the sidebar -> Table styles -> Select a style
Comment 4 Dieter 2018-05-09 12:42:59 UTC
(In reply to Telesto from comment #2)
> (In reply to Dieter Praas from comment #1)
> You're right, steps aren't working as expected :-). Small change (leave it
> at cell instead of table)
> 
> 1. Insert a table (2x2) (without formatting)
> 2. Select 1 or more cell's 
> 2. Table -> Properties -> Background
> 3. Select Color & Select Cell -> Press OK
> 4. Open the styles pane in the sidebar -> Table styles -> Select a style
> 5. No change in the first cell (if a single cell is selected)/ Or table if
> all cells are modified this way

Now it's reproducible for me with

Version: 6.1.0.0.alpha1+ (x64)
Build ID: 775d0f26beecffccf3ed27a6a011aff20d91f842
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-26_01:05:25
Locale: en-US (de_DE); Calc: CL
Comment 5 Xisco Faulí 2018-05-30 13:55:52 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.13; Render: default; 

@Jim, I thought you might be interested in this one...
Comment 6 Jim Raykowski 2018-06-13 06:48:37 UTC
Would the expected result be the same as applying a table style and using Ctrl-M to clear direct formatting?
Comment 7 Telesto 2018-07-14 15:46:00 UTC
(In reply to Jim Raykowski from comment #6)
> Would the expected result be the same as applying a table style and using
> Ctrl-M to clear direct formatting?

In my opinion, yes. However, lets ask UX-advise to be sure..
Comment 8 Heiko Tietze 2018-07-23 11:04:52 UTC
TS is not a real style but a template. But in any case the question is whether or no a direct formatting should be overridden. If the first cell has no particular definition in the TS it keeps what has been done by the user. BTW, TS work also in Calc where the selection is important.

I would say it's a WF/NOB due to the tainted definition of the feature.
Comment 9 Dieter 2020-06-06 15:27:59 UTC
Still the same behaviour in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 41d8b41767032681a9897b7551f011d450e3725e
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded
Comment 10 Dieter 2020-06-06 15:47:06 UTC
(In reply to Heiko Tietze from comment #8)
> TS is not a real style but a template.

How can a user now that? Tooltip in sidebar says "Table Styles". So I can unserstand, if user expects, that it behaves like styles.

> But in any case the question is
> whether or no a direct formatting should be overridden.

If you use Paragraph Style DF is overridden. So I would expect consistency and therefor that behaviour of Table Styles is the same.
Comment 11 Heiko Tietze 2022-01-31 16:13:23 UTC
(In reply to Dieter from comment #10)
> (In reply to Heiko Tietze from comment #8)
> > TS is not a real style but a template.
> 
> How can a user now that?

It's just what we have until bug 34391 is implemented (see also the META ticket on TS).

> > But in any case the question is
> > whether or no a direct formatting should be overridden.
> 
> If you use Paragraph Style DF is overridden. So I would expect consistency...

Sounds reasonable. Mike, what do you think?
Comment 12 Mike Kaganski 2022-01-31 16:23:21 UTC
(In reply to Heiko Tietze from comment #11)

As soon as we discuss something incorrectly called "table styles" (and which should not exist in the current form at all), I can only suggest to kill it with fire, and hope that proper table styles be implemented someday.
Comment 13 Dieter 2022-01-31 16:44:56 UTC
(In reply to Mike Kaganski from comment #12)
> I can only suggest to kill it with fire

So do you suggest to remove table "style" option in sidebar or to rename "table style" to "table template" or something else?

(In reply to Heiko Tietze from comment #11)
> > If you use Paragraph Style DF is overridden. So I would expect consistency...
> Sounds reasonable. Mike, what do you think?

Sorry, but I couldn't find an answer to this question in your comment.
Comment 14 Mike Kaganski 2022-01-31 16:51:53 UTC
(In reply to Dieter from comment #13)
> So do you suggest to remove table "style" option in sidebar or to rename
> "table style" to "table template" or something else?

I mean: remove current "table styles" as a feature from Writer completely. I.e., revert the GSoC project that had introduced it. (Yes, I realize it's a bit too radical. But that is my opinion.)
Comment 15 Heiko Tietze 2022-01-31 17:10:45 UTC
(In reply to Mike Kaganski from comment #14)
> ...revert the GSoC project that had introduced it

Too radical for the pettifogging UX people (and probably even more work meanwhile than fixing the bits and pieces).

Let's conclude that applying a style whether PS or CS or the "TS" should consistently overwrite existing DF. And if the current implementation of TS becomes superseded by a true style, even better.
Comment 16 Timur 2022-04-21 14:06:09 UTC
I think this makes no sense. 
First, as title put it, applying table style shouldn't remove direct formatting. 
More important, this is irrelevant "until bug 34391 is implemented".
Rather, focus on bug 104389 which is said to depend on bug 49437 .