Bug Hunting Session
Bug 117494 - 16K columns insted of 1K columns
Summary: 16K columns insted of 1K columns
Status: RESOLVED DUPLICATE of bug 50916
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-08 08:14 UTC by Markus KARG
Modified: 2018-05-08 08:48 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus KARG 2018-05-08 08:14:28 UTC
Description:
Microsoft Excel is able to write spreadsheet files having 16K columns. LibreOffice Calc is able to read spreadsheet files having 1K only. As a result, some spreadsheet files created by Microsoft Excel cannot be edited using LibreOffice Calc. It is an unrealistic option to ask people to not use more than 1K columns as Microsoft Excel still is the dominant competitor. So it would be good if LibreOffice is extended to support the missing 15K of columns.

Steps to Reproduce:
1. Using Microsoft Excel create a spreadsheet file having more than 1.024 colums.
2. Open the same file in LibreOffice calc.
3. Try to edit the 1.025th or 1.025th column.

Actual Results:  
The columns do not exist in LibreOffice calc.

Expected Results:
The columns exist in LibreOffice calc.


Reproducible: Always


User Profile Reset: No



Additional Info:
The problem is not only files created by Microsoft Excel but also simple CSV files written by third party software (no spreadsheet applications) which do not know about any limitation of the number of accessible columns.


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
Comment 1 Xavier Van Wijmeersch 2018-05-08 08:48:27 UTC
its a work in progress and a duplicate off Bug 50916

*** This bug has been marked as a duplicate of bug 50916 ***