Bug Hunting Session
Bug 117528 - Customize Keyboard Function list wrong for EPUB and PDF export options
Summary: Customize Keyboard Function list wrong for EPUB and PDF export options
Status: RESOLVED DUPLICATE of bug 108458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL: https://ask.libreoffice.org/en/questi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-09 21:36 UTC by LibreTraining
Modified: 2018-05-09 22:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LibreTraining 2018-05-09 21:36:26 UTC
Description:
When trying to add custom keyboard shortcuts for "Export to PDF" you will not find that in the Function list.

In LO v6.0.3.2
Customize > Keyboard tab > Category: Documents > Functions list

There is no "Export as PDF" in the Functions list.

EPUB is listed twice
PDF is listed twice

To match the actual menu items ...

1st EPUB should be: Export Directly as EPUB
2nd EPUB should be: Export as EPUB...

1st PDF should be: Export as PDF...
2nd PDF should be: Export Directly as PDF

I assigned keyboard shortcuts to test which showed me which function was which.
See screenshots here:
https://ask.libreoffice.org/en/question/79212/is-there-a-shortcut-to-save-document-in-pdf-format/?answer=154489#post-id-154489

Tested in Writer, but I assume it may also affect the other applications.


Steps to Reproduce:
See above

Actual Results:  
Functions list shows:

EPUB
EPUB

PDF
PDF


Expected Results:
Functions list should include:

Export as EPUB...
Export Directly as EPUB

Export as PDF...
Export Directly as PDF



Reproducible: Always


User Profile Reset: No



Additional Info:
Tested on:
Version: 6.0.3.2 (x64)
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group

I assume it will be the same on other operating systems.




User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Maxim Monastirsky 2018-05-09 22:00:32 UTC

*** This bug has been marked as a duplicate of bug 108458 ***