Bug Hunting Session
Bug 117535 - LibreOffice should not interpret characters formatting as word boundaries on Opentype fonts
Summary: LibreOffice should not interpret characters formatting as word boundaries on ...
Status: RESOLVED DUPLICATE of bug 61444
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.4.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2018-05-10 05:05 UTC by F. Tremmel
Modified: 2018-06-18 21:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example otf and character formating (927.94 KB, application/vnd.oasis.opendocument.text)
2018-05-10 05:05 UTC, F. Tremmel
Details
pdf-file of example odt-file (25.14 KB, application/pdf)
2018-06-18 18:02 UTC, F. Tremmel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description F. Tremmel 2018-05-10 05:05:39 UTC
Created attachment 142006 [details]
example otf and character formating

When using Opentype fonts, character formatting is interpreted as word boundaries.
This refers to hard as well as soft formatting with character styles.
I suspect that here the xml formatting marks are interpreted when rendering the font.

In the example you can see the illustration with and without character formatting.
Comment 1 Buovjaga 2018-06-18 16:34:54 UTC
What does this mean in practice? I don't understand just by looking at your document. I remove all the other text besides the Krokodil and Torpfosten examples and I see LibreOffice say "8 words".

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 F. Tremmel 2018-06-18 18:00:14 UTC
Hi Buovjaga

Many thanks for your response.

(In reply to Buovjaga from comment #1)
> What does this mean in practice? I don't understand just by looking at your
> document. I remove all the other text besides the Krokodil and Torpfosten
> examples and I see LibreOffice say "8 words".

This is interesting, but it only means that LibreOffice itself correctly recognizes the word boundaries.

In my case, it's about the implementation of Opentypefonts (OTF) and here the word boundaries are not recognized correctly.
Formats are interpreted here as word boundaries and the letters are replaced incorrectly.

Explanation to the example file.

The two words Krokodil and Torpfosten should clarify this.

Related to Krokodil
In the first line without formatting, the letters are replaced correctly. The transitions from "o" to the following letters are correct.
In the following three lines, individual letters are formatted (colored, bolded, with character styles). The transitions from "o" to the following letters are no longer correct.

The same applies to the second word (Torpfosten). Here are the transitions of "r" and "o". Again, LO behaves as one would expect at a word boundary.

Although the otf-font was embedded in the odt file, I add a PDF from the same file, if there are problems with the presentation.


I know that many never notice this behavior. In the school context, however, the ability to mark parts within words is very important.


> 
> Set to NEEDINFO.
> Change back to UNCONFIRMED after you have provided the information.

I hope I could clarify my request better.
Comment 3 F. Tremmel 2018-06-18 18:02:00 UTC
Created attachment 142878 [details]
pdf-file of example odt-file
Comment 4 F. Tremmel 2018-06-18 18:06:27 UTC
See previous comment.
Comment 5 Buovjaga 2018-06-18 18:14:56 UTC
Indeed, it becomes more obvious when one has the actual font. With a fallback sans serif font it was impossible to understand.

Can you point to some free font that shows this feature?
Comment 6 F. Tremmel 2018-06-18 18:40:42 UTC
(In reply to Buovjaga from comment #5)
> Indeed, it becomes more obvious when one has the actual font. With a
> fallback sans serif font it was impossible to understand.
> 
> Can you point to some free font that shows this feature?

On the fast the demo font to the used font:
http://www.will-software.com/demos.htm

There on the download link "Schulschriften OpenType"
Unfortunately, a Setup.exe. But it can also be unpacked with wine.

Several fonts are installed. For testing, it is best to select "LA" or "SAS".

I'm still looking for a free font. Real opentypefonts who use the substitutions are unfortunately rare.
Comment 7 Buovjaga 2018-06-18 18:46:36 UTC
(In reply to F. Tremmel from comment #6)
> Several fonts are installed. For testing, it is best to select "LA" or "SAS".

Can we upload LA to Bugzilla or is it illegal?
Comment 8 F. Tremmel 2018-06-18 18:49:11 UTC
(In reply to Buovjaga from comment #7)
> (In reply to F. Tremmel from comment #6)
> > Several fonts are installed. For testing, it is best to select "LA" or "SAS".
> 
> Can we upload LA to Bugzilla or is it illegal?

I am not sure.
For an upload to Bugzilla, I'm better looking for a free font.
Comment 9 Khaled Hosny 2018-06-18 19:00:00 UTC
Same underlying issue as bug 61444. Any text formatting causes a font change, which breaks any layout features across the change.

*** This bug has been marked as a duplicate of bug 61444 ***