Download it now!
Bug 117547 - FORMATTING: TOC in docx can cause hide previous character
Summary: FORMATTING: TOC in docx can cause hide previous character
Status: RESOLVED DUPLICATE of bug 129402
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-TableofContents
  Show dependency treegraph
 
Reported: 2018-05-10 12:41 UTC by anonim288
Modified: 2020-01-18 20:23 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
example, see "begin" word (10.54 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-05-10 12:41 UTC, anonim288
Details

Note You need to log in before you can comment on or make changes to this bug.
Description anonim288 2018-05-10 12:41:18 UTC
Created attachment 142012 [details]
example, see "begin" word

I create minimal docx in MS word (see attach). Inside MS word first line is 'this is begin', but in LO writer - 'this is begi' (without last letter).
Comment 1 Aron Budea 2018-05-11 21:56:32 UTC
Confirmed using LO 6.0.4.2 & 4.3.0.4 / Windows 7.
No issue with 4.2.0.4.
=> regression
Comment 2 Aron Budea 2018-06-18 15:40:54 UTC
Bibisected to the following range:
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=c619f8747bcf04454645774729ccf5d91fac55f1..92518d513fe021be58a0bbeb04fd9306eb23ebda

Out of which the following commit must be the culprit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=9679e9c23216decb5f9f25f85b04cb3f25211111
author		Vinaya Mandke <vinaya.mandke@synerzip.com>	2013-12-30 16:22:30 +0530
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-01-03 09:37:58 +0100

fdo#69649 Fix for pre-rendered Table Of Contents
Comment 3 Xisco Faulí 2019-04-17 16:16:26 UTC
Hi Serge,
Since you fixed bug 92786 which was introduced by the same commit as this one, I thought you might be interested in this issue...
Comment 4 Serge Krot (CIB) 2019-04-30 08:30:17 UTC
This issue has two problems:
1. The TOC field is started not from the beginning of the new paragraph, but after some text, therefor the last character is deleted because it is expected (in DOCX parser) to be end of paragraph symbol.
2. The TOC is not correctly finished, while the <w:fldChar w:fldCharType="separate"/> is placed execatly before end of the current paragraph node. If you add at least one character before the end of the paragraph the TOC will be created correctly and "new_paragraph" text will be inside the TOC.
Comment 5 Timur 2020-01-09 12:42:08 UTC
We see "begin" in master 6.5+ so WFM.
Let's guess a duplicate.

*** This bug has been marked as a duplicate of bug 129402 ***
Comment 6 anonim288 2020-01-18 20:23:54 UTC
Works for mee too, thanks to all.