Download it now!
Bug 117552 - Selecting "Notes" in the print dialog does not (immediately) change the orientation
Summary: Selecting "Notes" in the print dialog does not (immediately) change the orien...
Status: RESOLVED DUPLICATE of bug 99183
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2018-05-10 17:33 UTC by Emil Velikov
Modified: 2019-11-22 09:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Step1 (49.59 KB, image/png)
2018-05-10 17:37 UTC, Emil Velikov
Details
Step2 (54.12 KB, image/png)
2018-05-10 17:38 UTC, Emil Velikov
Details
Step3 (58.98 KB, image/png)
2018-05-10 17:38 UTC, Emil Velikov
Details
Step4 (59.77 KB, image/png)
2018-05-10 17:38 UTC, Emil Velikov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Velikov 2018-05-10 17:33:18 UTC
Description:
The orientation/preview is not updated immediately, workarounds are needed.

Steps to Reproduce:
1. Open an presentation, go to the print dialog
2. Select "Notes" in the Document drop-down menu
3. Select any other printer (even "Print to File...")
4. Switch back to the printer you want to use - portrait is preserved (yay) 

Actual Results:  
2. Actual orientation is still landscape, preview still shows landscape
3. Actual orientation and preview are updated to portrait
4. Portrait mode is preserved

See the attached step1/2/3/4 pictures.

Expected Results:
2. Should change the orientation and preview to portrait.
Step 3+4 should not be needed.


Reproducible: Always


User Profile Reset: No



Additional Info:
Problem is observed on
- Official Arch package LOver 5.4.4.2 and 6.0.4.2
Be that as-is or with SAL_USE_VCLPLUGIN={gtk,gtk3} SAL_SYNCHRONIZE=1 

- Official Elementary package LOver 6.0.3.2

Note:
 - Aron Budea cannot reproduce on this LO 5.4.4.2 + GTK2 TDF build on Ubuntu 17.10


The "Use OpenGL for all rendering" setting does not exist on the 5.4.4.2
package :-\



User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Comment 1 Emil Velikov 2018-05-10 17:37:40 UTC
Created attachment 142021 [details]
Step1
Comment 2 Emil Velikov 2018-05-10 17:38:10 UTC
Created attachment 142022 [details]
Step2
Comment 3 Emil Velikov 2018-05-10 17:38:29 UTC
Created attachment 142023 [details]
Step3
Comment 4 Emil Velikov 2018-05-10 17:38:45 UTC
Created attachment 142024 [details]
Step4
Comment 5 Buovjaga 2018-06-08 18:55:04 UTC
Repro, but not on Win. Repro also with gtk2 and gtk3 backends.
No repro with 3.6.7

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 67aaa98600269e6b8fa631146c3649a261369471
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 7th 2018

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 6 Xisco Faulí 2018-06-13 15:11:32 UTC
it seems the orientation problem was changed for good in https://cgit.freedesktop.org/libreoffice/core/commit/?id=57991f885e60d04e93bf5004d4fdceee7d29f3d8, so the step 2 is correct... However, it should change to A4 when we change the printer, I guess.

Adding Vasily Melenchuk to the loop to hear his opinion....
Comment 7 Xisco Faulí 2019-01-24 12:02:38 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: 0d46fb02f3f19d11db40b6c5335d78a3894502d7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Daniel, I thought you might be interested in this issue for the new print dialog...
Comment 8 Timur 2019-11-22 09:54:09 UTC
This looks like a duplicate of Bug 99183. 

But there was change in new print dialog. Test with Lo 6.5+.
In Print dialog Automatic orientation of Portrait is not correct, it sets Portrait, I would expect Landscape. Test in Windows with virtual printer.

Steps to Reproduce:
1. Open an presentation (like from bug 37924 or bug 99183), go to the print dialog. Observe Automatic orientation of Portrait (if you would expect Landscape).
2. Change Orientation to Portrait. Observe Landscape.
3. Change Orientation to Landscape. Observe Portrait that's not correct size.
4. Change Orientation to Automatic. Observe no change.

5. Select "Notes" as Type in Impress tab. Observe Portrait is fine.

So, this bug seems both duplicate and WFM, but we have another issue that we may track in the other bug (not to close and open a new one), unless it's already reported.

Note for Emil: please search before submitting and attach a single image with all steps so it's easier to follow.

*** This bug has been marked as a duplicate of bug 99183 ***