Bug 117555 - Shortcut keys wouldn't work under zh_TW (and probably most CJK) locale due to input method issue
Summary: Shortcut keys wouldn't work under zh_TW (and probably most CJK) locale due to...
Status: RESOLVED DUPLICATE of bug 115052
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-11 00:18 UTC by Franklin Weng
Modified: 2018-05-11 08:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Franklin Weng 2018-05-11 00:18:02 UTC
Shortcut keys with 
 - Ctrl+Space
 - Shift+Space
 - Ctrl+Shift
would not work under zh_TW locale (and probably most CJK locale) because they are related to our input method which 
 - IM is launched by ctrl-space
 - half/full type is switched by shift-space
 - input method selecting is going through by ctrl-shift

For example, in Calc the Ctrl-Space to select column and Shift-Space to select row can't work because the key combinations would be hijacked by our input method.

Ctrl+Shift+Space to add non-breaking space can't work in Writer because it will be implemented to switch from half-type to full-type characters.
Comment 1 Heiko Tietze 2018-05-11 08:44:51 UTC
We have bug 115052 about the fact that LibreOffice is ignorant about different languages. The ticket is about German umlauts that do not work and keys that are hard to reach on a non-english keyboard. 

I suggest to close this ticket as a duplicate.

PS: needsUX needs CC to ux-advice
Comment 2 Heiko Tietze 2018-05-11 08:45:14 UTC

*** This bug has been marked as a duplicate of bug 115052 ***