Bug 117610 - FILEOPEN DOCX: Incorrect numbering of references
Summary: FILEOPEN DOCX: Incorrect numbering of references
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx, implementationError
Depends on:
Blocks: DOCX-Fields
  Show dependency treegraph
 
Reported: 2018-05-14 14:17 UTC by Andrej Shadura
Modified: 2019-12-20 21:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
cross-ref1.docx (4.83 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-05-14 14:18 UTC, Andrej Shadura
Details
cross-ref1.odt (10.22 KB, application/vnd.oasis.opendocument.text)
2018-05-14 14:18 UTC, Andrej Shadura
Details
comparison MSO 2010 and LibreOffice 6.1 (20.04 KB, image/png)
2018-05-30 14:57 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej Shadura 2018-05-14 14:17:56 UTC
Description:
References point to wrong tables: the second reference should refer to the second table, but uses a number of the first one

Steps to Reproduce:
In the .docx document references should each have a number of a corresponding table


Actual Results:  
In LibreOffice Writer, references both have the number of the first table.
In Word, the targets of both references are incorrect.


Expected Results:
The first reference should point to the first table.
The second reference should point to the second table.


Reproducible: Always


User Profile Reset: No



Additional Info:
The .docx was produced by LibreOffice Writer.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Andrej Shadura 2018-05-14 14:18:30 UTC
Created attachment 142091 [details]
cross-ref1.docx
Comment 2 Andrej Shadura 2018-05-14 14:18:49 UTC
Created attachment 142092 [details]
cross-ref1.odt
Comment 3 Xavier Van Wijmeersch 2018-05-14 15:05:29 UTC
confirm, "References point to wrong tables: the second reference should refer to the second table, but uses a number of the first one"

Version: 5.4.8.0.0+
Build ID: cc68977f1be22ac0f4a15eb37e05ccba13a7a554
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-4, Time: 2018-05-12_11:32:19
Locale: nl-BE (en_US.UTF-8); Calc: group

Version: 6.1.0.0.alpha1+
Build ID: 96337c845c026236975d6a8af52867a5e8d28430
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-05-13_23:27:34
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 4 Dieter 2018-05-14 15:51:57 UTC
Changed to NEW, because of comment 3

Xavier, if you confirm a bug report, you can change the status to NEW.
Comment 5 Xisco Faulí 2018-05-30 14:57:13 UTC
Created attachment 142410 [details]
comparison MSO 2010 and LibreOffice 6.1
Comment 6 Xisco Faulí 2018-05-30 15:01:16 UTC
it seems the reference is display for a second when the file is loaded and then is updated...

Reproduced back to 

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 7 Cor Nouws 2019-02-05 18:17:32 UTC
(In reply to Xisco Faulí from comment #6)

> Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
in 3304 there is a short moment of display too, and then the content is hidden
Comment 8 Timur 2019-12-20 21:46:16 UTC
This bug was triaged wrongly.
Reported is filesave issue, as in Additional. 
Xavier didn't explain what he confirmed and Dieter wrongly changed to Fileopen. And Xisco and Cor may have fallen for that.

So, we open attachment 142092 [details] and save as DOCX, then reopen that DOCX preferably both in MSO and LO. Issue confirmed in LO 6.0.
But if saved in LO 6.5+, as DOC or DOCX, it reopens in MSO and LO correctly with proper references. WFM now.