Download it now!
Bug 117614 - GraphicExporter not always export correctly
Summary: GraphicExporter not always export correctly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-14 17:56 UTC by Fernand
Modified: 2018-05-22 12:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer doc with macro's and images to export (258.59 KB, application/vnd.oasis.opendocument.text)
2018-05-14 17:56 UTC, Fernand
Details
Document with more images who goes wrong (280.39 KB, application/vnd.oasis.opendocument.text)
2018-05-16 10:37 UTC, Fernand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fernand 2018-05-14 17:56:51 UTC
Created attachment 142099 [details]
Writer doc with macro's and images to export

Some images are with a lot of the same pixel color valued do not export correctly
us the macro's in the attached doc to test.

The GraphicExporter using the API is not working with images in a Writer Doc
test also using the attached doc.
Comment 1 Fernand 2018-05-15 08:10:46 UTC
(when the image is selected) in the UI) can also reproduce the same behaviour when using the "Save" option .

- when not changing the dimensions it works fine
- change the width from 10cm to 5cm and the image is misformed as with using the API
Comment 2 Jean-Baptiste Faure 2018-05-16 09:03:04 UTC
Which OS?
What is your version of LibreOffice?

Status set to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 3 Fernand 2018-05-16 10:36:12 UTC
J-B,
thanks for the interest

My current version is Collabora, but i found the same behaviour in the latest master off LO dev

Its hard to tell why the exporter misformed some images.

- only when changing the dimensions

- mostly with a lot off same mixels in it.

in my second document there are more pictures to test
Comment 4 Fernand 2018-05-16 10:37:16 UTC
Created attachment 142128 [details]
Document with more images who goes wrong
Comment 5 Fernand 2018-05-17 10:18:02 UTC
The macro's in the documents do work with the latest master LO 6.1 DEV because Tomaz has removed the URL properties.
never te less the testing using the UI is working in all versions
Comment 6 Miklos Vajna 2018-05-17 13:52:58 UTC
Confirmed, com.sun.star.drawing.GraphicExportFilter indeed doesn't accept a Writer image as an argument for setSourceDocument().
Comment 7 Commit Notification 2018-05-19 07:04:36 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aca5e1ba7f33c8913304b5f90ef478f316e64263

tdf#117614 svx: make drawing.GraphicExportFilter work with sw images

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.