Bug 117665 - Sidebar becomes nonfunctional after removing all category buttons and closing it when undocked.
Summary: Sidebar becomes nonfunctional after removing all category buttons and closing...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2018-05-17 11:15 UTC by Herman Tafintsev
Modified: 2019-05-31 02:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of this problem -- empty unusable panel (161.41 KB, image/png)
2018-05-17 11:15 UTC, Herman Tafintsev
Details
This button manipulates visibility of buttons-categories (188.55 KB, image/png)
2018-05-17 16:53 UTC, Herman Tafintsev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Herman Tafintsev 2018-05-17 11:15:03 UTC
Created attachment 142158 [details]
Screenshot of this problem -- empty unusable panel

Just tried to make "Styles" window look as a window and not as attachment to sidebar. So i undocked the sidebar and removed all category switch buttons. And then i closed this floating window...and i am not able to access Styles window anymore. Moreover, sidebar become COMPLETELY nonfunctional, because now i cannot add buttons back because context menu cannot be used.

Steps to reproduce:
1. Open "Styles" "window" by pressing F11 or selecting Styles -> Manage styles
2. Undock the sidebar panel
3. Remove all category buttons one by one moving from the top of the list to the bottom.
4. Close floating window.
5. Try to open "Styles" window again.

Operating system: Microsoft Windows 7 (WinNT 6.1.7601)
UAC status: Disabled
Application was running with access rights of: User
Comment 1 Dieter 2018-05-17 11:44:06 UTC
(In reply to Herman Tafintsev from comment #0)

> 3. Remove all category buttons one by one moving from the top of the list to
> the bottom.

I don't understand this step. I can't remove a button.
Comment 2 Herman Tafintsev 2018-05-17 16:53:35 UTC
Created attachment 142168 [details]
This button manipulates visibility of buttons-categories
Comment 3 Dieter 2018-05-17 19:46:52 UTC
Reproducible for me with

Version: 6.1.0.0.alpha1+ (x64)
Build ID: 775d0f26beecffccf3ed27a6a011aff20d91f842
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-26_01:05:25
Locale: en-US (de_DE); Calc: CL

and in 

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

Tested with writer and draw


Expected result: Button "Sidebar settings" remains
Comment 4 Xisco Faulí 2018-05-30 15:21:51 UTC
Regression introduced by:

author	Katarina Behrens <Katarina.Behrens@cib.de>	2017-10-18 12:50:59 +0200
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2017-10-21 15:02:50 +0200
commit	23467fa5cfa2feffbeba2177c0d393f8ebe1a0a3 (patch)
tree	71e3c86a862291530699fce94dcd90a61ab421c1
parent	0c46b3a9a384d5b70a708c3e9459a790dd815c63 (diff)
tdf#67770: Read/writer LastActiveDeck bits

Bisected with: bibisect-linux64-6.0

Adding Cc: to Katarina Behrens

Easy way to reproduce:
1. Go to Sidebar settings - Customization and deselect all options
2. Restart LibreOffice
-> Sidebar is empty!!
Comment 5 QA Administrators 2019-05-31 02:49:49 UTC
Dear Herman Tafintsev,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug