Bug 117698 - Impossible to define the replace field of the Find & Replace option using paste of the edit menu
Summary: Impossible to define the replace field of the Find & Replace option using pas...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste Find-Search
  Show dependency treegraph
 
Reported: 2018-05-18 22:05 UTC by jacques.trincavelli@club-internet.fr
Modified: 2018-05-30 15:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jacques.trincavelli@club-internet.fr 2018-05-18 22:05:29 UTC
Description:
I want to define the replace (or find) field of the Find & Replace window using the paste option OF THE EDIT MENU. But the clipboard contenu goes on to the text

Steps to Reproduce:
1. Open a new document writer file
2. Fill the clipboard whith some string 
3. Select Find & Replace
4. Try to paste on the "replace field" using paste command of the edit menu
5. The string is not in de replace field but in the text

Actual Results:  
The clipboard contenu goes on the text

Expected Results:
The clipboard contenu goes on the selected find & replace field


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Dieter 2018-05-19 11:55:53 UTC
Repro with

Version: 6.1.0.0.alpha1+ (x64)
Build ID: 775d0f26beecffccf3ed27a6a011aff20d91f842
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-26_01:05:25
Locale: en-US (de_DE); Calc: CL

Same with find-toolbar. Since it works with Strg+V, I would expect, that it also works via Edit => Paste.
Comment 2 Xisco Faulí 2018-05-30 15:30:59 UTC
This is the expected behaviour!
The find&replace is a modal dialog that allows the user to continue interacting with the document, thus, it's expected the content is paste in the document when using the menu.
Closing as RESOLVED NOTABUG