Bug 117711 - select all moves cursor to the end of the document
Summary: select all moves cursor to the end of the document
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 68674 (view as bug list)
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2018-05-20 08:02 UTC by lvm
Modified: 2019-06-10 09:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lvm 2018-05-20 08:02:55 UTC
Description:
select all moves cursor to the end of the document

Steps to Reproduce:
1. type several lines of text
2. move cursor anywhere expect the end of the document
3. press ^A or use edit->select all


Actual Results:  
cursor is moved to the end of the document (end of selection)

Expected Results:
cursor position should've been retained


Reproducible: Always


User Profile Reset: No



Additional Info:
For me the main annoyance of this behaviour is that when while editing a real-life-sized document I select all and apply formatting or language or something else to the whole document I end up at the end of the file and have to hunt for the place I was editing.

Also writer behaves inconsistently here: if I go to the top, select all and press down arrow cursor goes to the end of file but if press pgdn it goes a page and a bit down from the top - not quite where it would end if I pressed pgdn without select all but not EOF either.



User-Agent: Mozilla/5.0 (X11; Linux i686; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.3
Comment 1 Jean-Baptiste Faure 2018-05-21 16:54:17 UTC
I reproduce this behavior, but I am not sure if it is a defect.

Best regards. JBF
Comment 2 Dieter 2018-05-24 16:48:58 UTC
I also can reproduce it, but for it's consistent behaviour, because cursor always moves to the end of the selected text (paragraph, word, ...).

So for me NOTABUG.
Comment 3 lvm 2018-05-24 17:38:34 UTC
For me it means that it is consistently wrong, only less noticeable when selecting a single word. Unless selection is performed by cursor movement - with shift-keys or with a mouse, it should not affect the cursor position. And actually I know only two such commands: ^A to select all and double-click to select a word, so consistently probably is a too grand word for it, both is better. You mention a paragraph selection, but I googled hard and failed to find a paragraph selection command.
Comment 4 Dieter 2018-05-24 17:55:51 UTC
(In reply to lvm from comment #3)
> You mention a paragraph selection, but I googled hard and failed to find a paragraph selection command.

Ctrl+Shift+Arrow/Down



Let's design team decide, if it is a bug or not.
Comment 5 lvm 2018-05-24 18:55:38 UTC
This is not a paragraph selection, it is cursor movement with a shift - ^down moves cursor to the end of paragraph, shift-^down moves to the end of paragraph while extending selection.
Comment 6 Dieter 2018-05-24 19:07:02 UTC
(In reply to lvm from comment #5)
> This is not a paragraph selection, it is cursor movement with a shift -
> ^down moves cursor to the end of paragraph, shift-^down moves to the end of
> paragraph while extending selection.

Please also press the Ctrl-Button.
Comment 7 lvm 2018-05-24 19:13:13 UTC
^ means ctrl, sorry for being too old school
Comment 8 Nancy Tran 2018-05-25 06:35:43 UTC
In my opinion, I don't think this is a bug. I can understand the perspective of expecting the cursor to stay in the same place after pressing CTRL+A, but I can also see how the cursor (programmatically) needs to select all the text and why it ends up at the very end of the document. (The good thing about this is that after pressing CTRL+A, the vertical scrollbar doesn't automatically go to the end of the document.)

What I did notice was that the bar (i.e., |) still blinks after pressing CTRL+A at the end of the selected text. If the blinking cursor is too distracting to the user, then perhaps one option could be to not show the cursor when selecting the entire document.
Comment 9 lvm 2018-05-25 07:02:41 UTC
I don't find blinking cursor distracting at all. I believe that cursor must be highly visible at all times and I would consider it to be a bug if it stops being so at any time for any reason. What I find inconvenient and annoying is that the next cursor movement after 'select all' causes the document to jump many pages from where I was with no easy way to go back. I also find it strange and illogical that cursor may go beyond the visible region of the document at any time and cause such unpredictable behaviour.
Comment 10 Heiko Tietze 2018-05-25 07:10:06 UTC
Placing the cursor at the end of the text is common behavior in all apps. So I agree with the NOTABUG conclusion.

Btw, your workflow sounds very much like direct formatting and you definitely should try to get familiar with styles. While its a bit uncomfy at the beginning it will save you hours of work later. And the best, applying/changing styles doesn't move the cursor :-)
Comment 11 Thomas Lendo 2019-06-10 09:28:58 UTC
*** Bug 68674 has been marked as a duplicate of this bug. ***