Download it now!
Bug 117762 - Header Text formatting Outline and Shadow is not saving
Summary: Header Text formatting Outline and Shadow is not saving
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86 (IA32) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xls
Depends on:
Blocks: XLS
  Show dependency treegraph
 
Reported: 2018-05-23 15:11 UTC by michael
Modified: 2019-12-30 07:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
outline and shadow in header (8.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-12-30 07:46 UTC, Mike Kaganski
Details
Screenshot of the Font dialog for header in Excel 2016 (8.11 KB, image/png)
2019-12-30 07:58 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description michael 2018-05-23 15:11:15 UTC
Description:
I have a .xls spreadsheet using a header.  Click on the header button and under the header tab in the center area I have the text formatted with custom header text >> font effects >> Outline and Shadow check boxes checked. Click OK then OK File then Save. Close out Libre and open the spreadsheet back up and its not saved.  I use this spreadsheet often and typically have to go through these motions at least 20-30 times a day if not more.  Would be excellent if it can be resolved.

Steps to Reproduce:
I have a .xls spreadsheet using a header.  Click on the header button and under the header tab in the center area I have the text formatted with custom header text >> font effects >> Outline and Shadow check boxes checked. Click OK then OK File then Save. Close out Libre and open the spreadsheet back up and its not saved.  I use this spreadsheet often and typically have to go through these motions at least 20-30 times a day if not more.  Would be excellent if it can be resolved.

Actual Results:  
n/a

Expected Results:
n/a


Reproducible: Always


User Profile Reset: No



Additional Info:
n/a


User-Agent: Mozilla/5.0 (Windows NT 6.3; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 raal 2018-05-23 20:23:16 UTC
Confirm.Version: 6.1.0.0.alpha1+
Build ID: 137c38a1ba01c51c421f695e1558d2c1499c6627
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: cs-CZ (cs_CZ.UTF-8); Calc: group
and Version 4.1.0.0.alpha0+
Comment 2 QA Administrators 2019-12-04 04:20:48 UTC Comment hidden (obsolete)
Comment 3 Mike Kaganski 2019-12-30 07:46:43 UTC
Created attachment 156841 [details]
outline and shadow in header

Confirm in Version: 6.4.0.1 (x64)
Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

The attached ODS may be checked in the header dialog or preview; then saved as XLS and reloaded to see that the operation resets the attributes.
Comment 4 Mike Kaganski 2019-12-30 07:56:05 UTC
But checking in Excel 2016, there's no option to make text in header have these properties - so likely it's not a bug, but simply XLS format (and probably XLSX too, since the dialog in Excel is not specific to XLS) doesn't support this.

Thus closing NOTABUG.
Comment 5 Mike Kaganski 2019-12-30 07:58:25 UTC
Created attachment 156842 [details]
Screenshot of the Font dialog for header in Excel 2016