Bug 117769 - Graphic Corruption on slideshow with Gradient and Animations
Summary: Graphic Corruption on slideshow with Gradient and Animations
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2018-05-24 04:01 UTC by Luke
Modified: 2019-09-05 11:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Page 3 in slideshow on LO 6.1 (1.13 MB, image/png)
2018-05-24 04:01 UTC, Luke
Details
LO 6.0 correctly renders the gradient background (1.10 MB, image/png)
2018-05-24 04:49 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2018-05-24 04:01:14 UTC
Created attachment 142258 [details]
Page 3 in slideshow on LO 6.1

The ellipsoid gradient has rendering errors on Linux in slides with custom animations. 


Steps to reproduce:
1. On Linux with a recent build of LO 6.1, open attachment 141900 [details] 
2. Start slideshow
3. Press space to page 3
4. Note the rendering glitches with the Ellipsoid Gradient background
Comment 1 Luke 2018-05-24 04:49:53 UTC
Created attachment 142260 [details]
LO 6.0 correctly renders the gradient background
Comment 2 Luke 2018-05-24 04:52:38 UTC
I bisected this to https://cgit.freedesktop.org/libreoffice/core/commit/?id=b524de95


b524de950c6eb0bc61d05d41fe69b67ab59b16c6 is the first bad commit
commit b524de950c6eb0bc61d05d41fe69b67ab59b16c6
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Wed Apr 11 12:09:45 2018 +0100

    Related: rhbz#1396729 use cairo_surface_create_similar


Caolán,

Could you please take a look at this?
Comment 3 Caolán McNamara 2018-05-24 12:43:48 UTC
X or wayland ?, X I guess.

I can't reproduce, but this has been the case for all the XRender glitches which I think is behind those. Does the gtk2 backend have any issue here ?
Comment 4 Buovjaga 2018-05-24 12:58:16 UTC
Using X here. All the backends (gen, gtk2, gtk3, kde4) show issues, with different segments of the gradients being blocky and showing the underlying picture through some segments.

Arch Linux 64-bit
Version: 6.1.0.0.alpha1+
Build ID: 5956828c88501ef1366e60010b05053a8e1e642e
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on May 23rd 2018
Comment 5 QA Administrators 2019-05-31 02:50:08 UTC Comment hidden (obsolete)
Comment 6 Luke 2019-09-05 11:56:44 UTC
Seems fixed now in Version: 6.4.0.0.alpha0+
Build ID: 1496a1831d1be0a2d24be9fe3ecf627b2664e938

with xf86-video-intel: 2.99.917-870-g6f4972d5