Bug 117790 - Caption order, caption positions for Lithuanian language
Summary: Caption order, caption positions for Lithuanian language
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCaption
  Show dependency treegraph
 
Reported: 2018-05-25 05:29 UTC by opensuse.lietuviu.kalba
Modified: 2021-11-07 04:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document with default wrong order (72.38 KB, application/vnd.oasis.opendocument.text)
2018-05-25 05:31 UTC, opensuse.lietuviu.kalba
Details
wrong and good caption order in same document (131.94 KB, application/vnd.oasis.opendocument.text)
2018-05-25 05:32 UTC, opensuse.lietuviu.kalba
Details
Screenshot of document with default/wrong and good caption order/place/name (122.33 KB, image/png)
2018-05-25 05:35 UTC, opensuse.lietuviu.kalba
Details
patch (4.17 KB, text/plain)
2019-10-28 15:07 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2018-05-25 05:29:45 UTC
Description:
Caption order should default to “Numbering first” for Lithuanian language.
After number, word should be lower case.
Table's caption should be by default before table, not below table.

Steps to Reproduce:
1. In Lithuanian environment in LibreOffice Writer add
a) table
b) image
2. Insert caption

Actual Results:  
Now if I add caption, I get by default:
Lentelė 1: Title.
Paveikslas 1: Title.


Expected Results:
But caption order should be:
"1 lentelė. Title." (and first letter L in "lentelė" is lower case)
"1 paveikslas. Title." OR "1 pav. Title." (we much more often use abrevation, not full word)


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Versija: 6.0.4.2
Darinio identifikatorius: 00m0(Build:2)
Procesoriaus gijos: 4; OS:Linux 4.4; Sąsajos pateikimas: numatytasis; VCL: kde4; 
Lokalė: lt-LT (lt_LT.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 opensuse.lietuviu.kalba 2018-05-25 05:31:18 UTC
Created attachment 142269 [details]
Example document with default wrong order
Comment 2 opensuse.lietuviu.kalba 2018-05-25 05:32:19 UTC
Created attachment 142270 [details]
wrong and good caption order in same document
Comment 3 opensuse.lietuviu.kalba 2018-05-25 05:35:37 UTC
Created attachment 142271 [details]
Screenshot of document with default/wrong and good caption order/place/name
Comment 4 Xisco Faulí 2018-06-25 09:06:48 UTC
Hello,

You can change the order from the Options button in the 'insert caption' dialog.
Closing as RESOLVED NOTABUG
Comment 5 opensuse.lietuviu.kalba 2018-06-25 09:16:24 UTC
This indeed is bug.

In https://wiki.documentfoundation.org/ReleaseNotes/6.1 was stated that:

"Tools ▸ Options ▸ Writer ▸ AutoCaption ▸ Caption Order should default to “Numbering first” for Hungarian (locale “hu”) and to “Category first” for all other locales."

However this is true not only for Hungarian language, but for Lithuanian language also.
Comment 6 Xisco Faulí 2018-06-25 09:21:56 UTC
(In reply to opensuse.lietuviu.kalba from comment #5)
> This indeed is bug.
> 
> In https://wiki.documentfoundation.org/ReleaseNotes/6.1 was stated that:
> 
> "Tools ▸ Options ▸ Writer ▸ AutoCaption ▸ Caption Order should default to
> “Numbering first” for Hungarian (locale “hu”) and to “Category first” for
> all other locales."
> 
> However this is true not only for Hungarian language, but for Lithuanian
> language also.

Ok, Thanks for the info.
Adding Stephan as Cc
Comment 7 Stephan Bergmann 2018-06-25 11:04:10 UTC
All I took care of with <https://cgit.freedesktop.org/libreoffice/core/commit/?id=552bebc85d907748dcd72b7978a00a3eee7c4f34> is that the Hungarian-locale--specific

>       <prop oor:name="CaptionOrderNumberingFirst">
>         <value xml:lang="hu">true</value>
>       </prop>

in officecfg/registry/data/org/openoffice/Office/Writer.xcu is actually honored.  I have no idea about the relevant code producing localized captions.

When the above data in officecfg/registry/data/org/openoffice/Office/Writer.xcu is changed in a recent LO master build to

>       <prop oor:name="CaptionOrderNumberingFirst">
>         <value xml:lang="hu">true</value>
>         <value xml:lang="lt">true</value>
>       </prop>

by adding a line for lt (and removing any existing user profile, see <https://wiki.documentfoundation.org/UserProfile>, to avoid "you may still see unexpected values if you either changed these settings manually in the past, or even if you merely keep using a pre-existing user installation" explained in <https://wiki.documentfoundation.org/ReleaseNotes/6.1#Localized_Settings>), running LO (built with --with-lang=lt, on Linux) as `LC_ALL=lt_LT.UTF-8 instdir/program/soffice --writer`, using the "Insert Table (Vald+F12)" icon to insert a table, then "Insert - Caption..." to open the "Pavadinimo jterpimas" dialog, typing "Title." into "Pavadinimas", "Per..." shows

  1. Lentelė: Title.

not

  1 lentelė. Title.

as suggested in comment 0.  I have no idea if the former is acceptable.

Somebody who knows about the relevant Writer code and/or Lithuanian localization should do the necessary changes.  The change to officecfg/registry/data/org/openoffice/Office/Writer.xcu I showed above may be one necessary change, but there's probably more.
Comment 8 Stephan Bergmann 2018-06-25 11:08:02 UTC
(In reply to Stephan Bergmann from comment #7)
[...]
> jterpimas" dialog, typing "Title." into "Pavadinimas", "Per..." shows

"Per..." should read "Peržiūra"
Comment 9 opensuse.lietuviu.kalba 2018-06-25 11:28:46 UTC
@Stephan, thanks!

@Rimas, can you please look at this (Rimai, ar galėtum žvilgtelėti?)
Comment 10 Rimas Kudelis (only watching bugs where I'm in CC list) 2018-06-25 17:04:30 UTC
Adding the locale owner.

Modestai, žvilgtelk prašau į šitą pranešimą.
Comment 11 Modestas Rimkus 2018-06-27 18:14:16 UTC
For Lithuanian default caption order to be correct, together with setting Caption Order default value to "Numbering first", Numbering Separator default value must also be changed from dot+space to space only. I have no idea if and how this can be achieved so I would need assistance from a more technical person (as well as with changing the default caption position). Otherwise, current configuration is better from the two evils.
Capitalization is a translation issue that I can handle after that.
Comment 12 QA Administrators 2019-07-02 02:43:23 UTC Comment hidden (obsolete)
Comment 13 Julien Nabet 2019-10-28 15:07:11 UTC
Created attachment 155371 [details]
patch

Modestas Rimkus: In the attached patch, I included Stephan's change about CaptionOrderNumberingFirst + added these blocks
+           <prop oor:name="NumberingSeparator">
+              <value xml:lang="lt"> </value>
+            </prop>

(it's just a plain space but if you need other type of space, you can change this.
Comment 14 Julien Nabet 2019-10-28 15:13:48 UTC
Modestas Rimkus: if you build locally, I noticed that, in addition to do:
"make officecfg.build"
you also need to do:
"make postprocess"

then only, remove your dev LO profile and test.
Comment 15 Modestas Rimkus 2019-10-28 15:19:40 UTC
Julien Nabet: Thanks! But no, I don't build locally. Can the patch be included and tested on nightly builds or anywhere else?
Comment 16 Julien Nabet 2019-10-28 15:24:33 UTC
(In reply to Modestas Rimkus from comment #15)
> Julien Nabet: Thanks! But no, I don't build locally. Can the patch be
> included and tested on nightly builds or anywhere else?

I submitted a patch on gerrit here:
https://gerrit.libreoffice.org/#/c/81612/

If Jenkins doesn't complain, I'll push this. Once it's pushed, you'll be able to test this in 24/48h with a daily build.
Comment 17 Commit Notification 2019-10-28 16:26:27 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d13219b10a69a2533b1afe258edeadac2b5c0651

Related tdf#117790: Caption order, caption positions for Lithuanian language

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Modestas Rimkus 2019-11-02 22:25:22 UTC
The Caption Order default value is now set to Numbering First for Lithuanian.

Numbering Separator is set to emty space in the AutoCaption options window. However, Numbering Separator is still set to dot+space by default whenever I choose "Insert – Caption", and has to be modified manually for each caption inserted that way.

Can the default Numbering Separator in "Insert – Caption" dialog be changed to space instead of dot+space, too?


Verified on:
Versija: 6.4.0.0.alpha1+
Darinio identifikatorius: 80109586e6cb6d3e2e0a53a9079c3125ec9b8368
Procesoriaus gijos: 8; OS:Linux 4.15; Sąsajos pateikimas: numatytasis; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-01_23:56:52
Lokalė: lt-LT (lt_LT.UTF-8); Sąsajos kalba: lt-LT
Calc: threaded
Comment 19 Julien Nabet 2019-11-03 08:19:14 UTC
(In reply to Modestas Rimkus from comment #18)
> ...
> Can the default Numbering Separator in "Insert – Caption" dialog be changed
> to space instead of dot+space, too?
> ...
I don't know what should be changed then but could you test these:
1) on a brand new document?
2) on a brand new document after having renamed your LO directory profile (see https://wiki.documentfoundation.org/UserProfile)
If it still doesn't work, I must recognize I'm stuck.
Comment 20 Modestas Rimkus 2019-11-03 19:00:16 UTC
(In reply to Julien Nabet from comment #19)
> (In reply to Modestas Rimkus from comment #18)
> I don't know what should be changed then but could you test these:
> 1) on a brand new document?
> 2) on a brand new document after having renamed your LO directory profile
> (see https://wiki.documentfoundation.org/UserProfile)
> If it still doesn't work, I must recognize I'm stuck.

I tried with a new document and also reset my user profile through safe mode, but got the same result - default Numbering Separator in "Insert – Caption" dialog is different from the one in AutoCaption options (separator is correct in the latter).

Should I file a new bug that configuration that you've changed does not affect the dialog?
Comment 21 Julien Nabet 2019-11-07 15:31:18 UTC
(In reply to Modestas Rimkus from comment #20)
> ...
> Should I file a new bug that configuration that you've changed does not
> affect the dialog?

Taking a look, it seems the problem is due to the fact there are 2 different dialogs. Indeed searching about m_xNumberingSeparatorED, we've got:
- sw/source/ui/frmdlg/cption.cxx (which seems to be used in the dialog where there's still the pb)
- sw/source/ui/frmdlg/optload.cxx (which corresponds to the part in options/tools/...)
I don't know if or how they should synchronize. I'm stuck here.

Anyway since the problem is still there and to answer to your question, no need to submit a new bugtracker. Let's remove target 6.4.0 since the patch isn't sufficient to fix the main problem.
Comment 22 QA Administrators 2021-11-07 04:23:00 UTC
Dear opensuse.lietuviu.kalba,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug