Download it now!
Bug 117859 - [GTK3] Crash in welded "Tab color" dialog.
Summary: [GTK3] Crash in welded "Tab color" dialog.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-28 16:14 UTC by Hussam Al-Tayeb
Modified: 2018-05-31 08:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File that exhibits the issue. (6.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-05-28 16:14 UTC, Hussam Al-Tayeb
Details
gdb log from official daily build. (37.36 KB, text/plain)
2018-05-29 11:15 UTC, Hussam Al-Tayeb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hussam Al-Tayeb 2018-05-28 16:14:06 UTC
Created attachment 142352 [details]
File that exhibits the issue.

Reproduction steps:

1) Open the attached file.
2) Click on Sheet2 (It needs to be Sheet2).
3) Right click on the label "Sheet2" and select "Tab Color...".
4) Press the Tab key on your keyboard.

Libreoffice said it encountered an issue and offered to recover the file.

GDB output https://pastebin.com/jXuxFkBp
Comment 1 Xisco Faulí 2018-05-28 17:15:54 UTC
Thank you for reporting this issue.

I can't reproduce it in

Version: 6.1.0.0.beta1+
Build ID: da49f4aeb8d5e9a7d2cba8855d911e7cc1d2f1e2
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

Could you please paste the info from Help - about LibreOffice ?
Comment 2 Hussam Al-Tayeb 2018-05-28 17:19:44 UTC
Version: 6.2.0.0.alpha0+
Build ID: 796bee47e90efee7c076f6acdc2a95004ed081d0
Comment 3 Hussam Al-Tayeb 2018-05-28 17:21:38 UTC
Sorry, that wasn't the whole thing.

Version: 6.2.0.0.alpha0+
Build ID: 796bee47e90efee7c076f6acdc2a95004ed081d0
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 4 Xisco Faulí 2018-05-28 17:25:54 UTC
Probably a crash introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=4883fd31141c3598b25a123033297f847cd18552...

@Caolán, would you mind taking a look?
Comment 5 Xavier Van Wijmeersch 2018-05-29 06:41:54 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: e7fe9094831036c295bf448737869a47f1873e3f
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 6 Xisco Faulí 2018-05-29 08:41:26 UTC
not reproduced in

Versió: 6.2.0.0.alpha0+
ID de la construcció: 8f9f66e8d2bae94c1f469ffc51bdbffeba853a2b
Fils de CPU: 4; SO: Linux 4.13; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 7 Hussam Al-Tayeb 2018-05-29 11:14:47 UTC
It crashes with the build from:
https://dev-builds.libreoffice.org/daily/master/Linux-archive-x86_64@80-updater/current/

I'll attach the new gdb log file.
Comment 8 Hussam Al-Tayeb 2018-05-29 11:15:21 UTC
Created attachment 142374 [details]
gdb log from official daily build.
Comment 9 Xisco Faulí 2018-05-29 11:48:14 UTC
> It crashes with the build from:
> https://dev-builds.libreoffice.org/daily/master/Linux-archive-x86_64@80-
> updater/current/

Ohhhh, I see you're using the updater builds...

I can reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 8f9f66e8d2bae94c1f469ffc51bdbffeba853a2b
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: th-TH (ca_ES.UTF-8); Calc: group threaded(In reply to Hussam Al-Tayeb from comment #7)

but not with a local build...

@Markus, @Caolán, might it be related to the gtk3 version by the machine used to build the updater releases?
Comment 10 Hussam Al-Tayeb 2018-05-29 13:12:17 UTC
Both updater builds and local builds (I tried both gcc 7.3.1 and clang 6.0) here show the issue.
Perhaps the Linux environment on my machine is close to the one on the machine that does the updater builds.
My GTK+ version is 3.22.30
Comment 11 Caolán McNamara 2018-05-29 14:05:05 UTC
I can generally reproduce this
Comment 12 Caolán McNamara 2018-05-30 19:55:10 UTC
https://gerrit.libreoffice.org/#/c/55087/ should fix this
Comment 13 Hussam Al-Tayeb 2018-05-30 20:01:40 UTC
I will test now.
Comment 14 Commit Notification 2018-05-30 20:30:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fd52a23e4428bd9447643fd9c9c58905a4e7250b

tdf#117859 crash in Tab Color a11y

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-05-31 08:13:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e547b1a36061f3ece12baa348bdd3814aa745ae4&h=libreoffice-6-1

tdf#117859 crash in Tab Color a11y

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.