Bug 117907 - VIEWING, PDF: Justifying Syriac and Arabic text creates clutter in LibreOffice Writer
Summary: VIEWING, PDF: Justifying Syriac and Arabic text creates clutter in LibreOffic...
Status: RESOLVED DUPLICATE of bug 116344
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-30 17:06 UTC by vaaydayaasra
Modified: 2018-06-21 19:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with Syriac text (120.31 KB, image/png)
2018-05-30 17:06 UTC, vaaydayaasra
Details
A generated PDF with Syriac text (27.50 KB, application/pdf)
2018-05-30 17:10 UTC, vaaydayaasra
Details
ODT document used to create the screenshot and the PDF (13.91 KB, application/vnd.oasis.opendocument.text)
2018-05-30 17:12 UTC, vaaydayaasra
Details
A generated PDF with Arabic text (16.49 KB, application/pdf)
2018-05-30 17:13 UTC, vaaydayaasra
Details
ODT document used to create the Arabic PDF (10.31 KB, application/vnd.oasis.opendocument.text)
2018-05-30 17:15 UTC, vaaydayaasra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vaaydayaasra 2018-05-30 17:06:16 UTC
Created attachment 142417 [details]
Screenshot with Syriac text

Justifying a paragraph in LibreOffice Writer with text written in the Syriac script (Unicode block U+0700-U+074F) creates graphic clutter between every word. See the attached screenshot where the first paragraph is justified and the second is right-aligned. The second paragraph looks as it should, whereas the first paragraph shows a small line added at the end of each word. If you zoom in or out, some of the lines may disappear, but when you create a PDF, they are all there.

The same problem occurs with nearly all the Syriac fonts I have tried, including Serto Batnan, Estrangelo Antioch, East Syriac Ctesiphon and Serto Urhoy (all part of the ttf-xfree86-nonfree-syriac Debian package, also available through www.bethmardutho.org). For the last two, the clutter is not visible on screen but shows up if you create a PDF. With East Syriac Adiabene, the problem doesn't seem to occur. Sometimes the same problem occurs with Arabic text, as well. See the attached screenshots, PDFs and the documents used to create them.

Another user on Launchpad confirmed that the same problem persists in LibreOffice 6.0.3.2.

This bug was first reported on Launchpad at https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1772414
Comment 1 vaaydayaasra 2018-05-30 17:10:34 UTC
Created attachment 142418 [details]
A generated PDF with Syriac text
Comment 2 vaaydayaasra 2018-05-30 17:12:12 UTC
Created attachment 142419 [details]
ODT document used to create the screenshot and the PDF
Comment 3 vaaydayaasra 2018-05-30 17:13:57 UTC
Created attachment 142420 [details]
A generated PDF with Arabic text
Comment 4 vaaydayaasra 2018-05-30 17:15:24 UTC
Created attachment 142421 [details]
ODT document used to create the Arabic PDF
Comment 5 Buovjaga 2018-06-21 16:09:45 UTC

*** This bug has been marked as a duplicate of bug 108604 ***
Comment 6 Khaled Hosny 2018-06-21 17:15:48 UTC
The Syriac issue was fixed in bug 116344.
Comment 7 V Stuart Foote 2018-06-21 19:39:10 UTC
lets move this mishandling of Syriac script to bug 116344, with additional work on calculating Kashida still needed but avoided for now with 6.1.0 release.

*** This bug has been marked as a duplicate of bug 116344 ***