Bug Hunting Session
Bug 117972 - Incorrect source string for UI in Pootle - Libreoffice 6 and Master
Summary: Incorrect source string for UI in Pootle - Libreoffice 6 and Master
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta1+
Hardware: All All
: medium minor
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.2.0 target:6.1.1
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-02 09:07 UTC by Valter Mura
Modified: 2018-08-21 14:53 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valter Mura 2018-06-02 09:07:32 UTC
Description:
There is a string without any text in Pootle, LibreOffice 6 and Master.
It seems an error to be corrected. Links:

https://translations.documentfoundation.org/it/libo60_ui/translate/extensions/messages.po#unit=141604997

https://translations.documentfoundation.org/it/libo_ui/translate/extensions/messages.po#unit=137772880


Steps to Reproduce:
1. Open Pootle
2. Go to the links indicated in the Description
3.

Actual Results:  
You find the incorrect string

Expected Results:
Delete the string if incorrect; modify it if there is something wrong with it


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Julien Nabet 2018-08-19 19:54:43 UTC
UX: before talking about translation, we need an English message for these first.
Any thoughts?
Comment 2 Heiko Tietze 2018-08-20 11:18:21 UTC
It looks to me that this file was created by Caloan during the move to gettext  https://gerrit.libreoffice.org/#/c/40171/. And looking into the code I guess the string for RID_UPDATE_BUBBLE_DOWNLOADING dynamically takes the actual downloaded bytes https://opengrok.libreoffice.org/xref/core/extensions/source/update/check/updatehdl.cxx#653.

So my take is to keep the string empty - or to change some lines in the code.
Comment 3 Julien Nabet 2018-08-20 12:01:49 UTC
(In reply to Heiko Tietze from comment #2)
> It looks to me that this file was created by Caloan during the move to
> gettext  https://gerrit.libreoffice.org/#/c/40171/. And looking into the
> code I guess the string for RID_UPDATE_BUBBLE_DOWNLOADING dynamically takes
> the actual downloaded bytes
> https://opengrok.libreoffice.org/xref/core/extensions/source/update/check/
> updatehdl.cxx#653.

I suppose you meant https://cgit.freedesktop.org/libreoffice/core/commit/?id=00657aef09d854c74fb426a935a3e8b1fc390bb0 since the commit pointed has been abandoned.
The thing is this commit is a big refactoring, RID_UPDATE_BUBBLE_DOWNLOADING is older than this.
I can check again but I think it's several years old.
The pb is I don't know how to test this with master sources because, LO must detect an update to download. Obviously, with master sources updated almost daily in my case, you can't be more up-to-date.

> 
> So my take is to keep the string empty - or to change some lines in the code.
Hmm, a bit weird to let an string, above all a translatable string, empty, isn't it?
Comment 4 Heiko Tietze 2018-08-21 08:01:17 UTC
(In reply to Julien Nabet from comment #3)
> > So my take is to keep the string empty - or to change some lines in the code.
> Hmm, a bit weird to let an string, above all a translatable string, empty,
> isn't it?

Admitted. I can delete the string without an issue but the potential impact is out of my skills. Maybe the bubble thing is not used at all, maybe it crashes under certain conditions... better a real dev takes a look.
Comment 5 Julien Nabet 2018-08-21 08:10:23 UTC
(In reply to Heiko Tietze from comment #4)
> ...
> Admitted. I can delete the string without an issue but the potential impact
> is out of my skills. Maybe the bubble thing is not used at all, maybe it
> crashes under certain conditions... better a real dev takes a look.

Out of my skills too. I don't know who may help here. It's very specific so can't be found in "Find Expert" wiki page.
Agree with you, I wouldn't remove the string for the moment.
Comment 6 Caolán McNamara 2018-08-21 08:42:31 UTC
this string has been blank since ooo times, probably the older tooling just skipped such empty strings. I suspect, from the surrounding strings, that "Click the icon to pause." would be a good string here
Comment 7 Commit Notification 2018-08-21 10:58:18 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=917b0aec183f50c119d6a98275ab6623accdfca6

tdf#117972 - Empty UI string

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Julien Nabet 2018-08-21 12:08:39 UTC
Just for curiosity, will it be automatically included in Pootle soon or is it a manual process? What's the expected delay?
Comment 9 Julien Nabet 2018-08-21 12:10:19 UTC
Also any chance for a backport in 6.1 branch?
Comment 10 Heiko Tietze 2018-08-21 12:11:46 UTC
Strings are automatically updated and I cherry-picked for 6.1 right now.
Comment 11 Julien Nabet 2018-08-21 12:13:36 UTC
(In reply to Heiko Tietze from comment #10)
> Strings are automatically updated and I cherry-picked for 6.1 right now.

Thank you for the very fast feedback! :-)
Comment 12 Commit Notification 2018-08-21 14:42:30 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4a20d15792ed981612b0414a39e27035c02fed19&h=libreoffice-6-1

tdf#117972 - Empty UI string

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.